Closed Bug 1325277 Opened 3 years ago Closed 3 years ago

Mochitest plain perma leak in dom/animation/test/css-animations

Categories

(Core :: DOM: Animation, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla53
Tracking Status
firefox51 --- unaffected
firefox52 + unaffected
firefox53 + fixed

People

(Reporter: ahal, Assigned: mccr8)

References

Details

Attachments

(1 file)

https://archive.mozilla.org/pub/firefox/try-builds/ahalberstadt@mozilla.com-46239c8ae40ed066d6ed784a1d91a0811c71f7df/try-linux-debug/try_ubuntu32_vm-debug_test-mochitest-1-bm02-tests1-linux32-build232.txt.gz

Mochitest leaks haven't been turning the job orange lately and this is one of the leaks that slipped through in the meantime.

Bug 1325148 will both fix the harness as well as whitelist this specific leak (leakchecking for the dom/animation/test/css-animations directory will be temporarily disabled). This will allow me to land the fix ASAP.

That means this leak still won't show up on treeherder, but it exists and will need to be fixed.
[Tracking Requested - why for this release]: Leaks are bad.

Looks like XHR is leaking, among other things.

Which is odd, since there are no hits for "XMLHttpRequest" in the dom/animation/test/css-animations directory...

Not just that, but this XHR that leaks was poked at by chrome code in weird ways; note the nsXMLHttpRequestXPCOMifier in the list.

So it's possible this is similar to bug 1325158.
Depends on: 1325158
There's also a leak happening under dom/xhr/tests in bug 1325274. We filed separate bugs for everything but it's very possible that a single leak is causing multiple bugs. Feel free to dupe if they look the same.
I think we should fix bug 1325158 and then do a try push to see whether the other problems are gone too...
Tracking 51/52/53+ since this is a perma leak.
Shouldn't it be possible to figure out when this started by bisecting the logs?  (Would that help?)
Leak checking itself isn't actually broken, so it's easy to verify if these permaleaks exist on older branches by looking at the treeherder failure summary for the appropriate job (may need to check all chunks though).

The mochitest regression landed on 52, so none of these leaks need to be fixed on 51.
I'm having trouble finding instances of this failure (as I'd like to figure out where it was introduced), and the log in comment 0 has expired. Was this in Linux 32 debug Mochitests? I looked at the raw logs and I found where dom/animation/test/css-animations was running, but I didn't see any leaks. What am I missing? Thanks.

https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&revision=a61af3f4bc6ee9fc425239806bdf988c65c1e81f
Flags: needinfo?(ahalberstadt)
Bug 1325148 selectively disabled leak checking when running that directory, so now you'll need to run a try push that removes this line:
https://dxr.mozilla.org/mozilla-central/source/testing/mochitest/runtests.py#2221

I took the liberty of doing that here:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=0b63cff8e2dd9fe5b9fda8fac743d6762326cd30

Feel free to 'Add New Jobs' if you need to.
Flags: needinfo?(ahalberstadt)
Ah, I guess you were looking at older pushes.. I think this was happening on all platforms, but definitely linux 32 based on the log in comment 0. Maybe it was introduced after Dec. 18th? Or possibly it's actually intermittent and not perma fail.

Let's verify this is still happening currently in my try push from comment 8. After that we could possibly bisect on try by pushing from older bases.
I'll retrigger and put up a patch to reenable checking if it looks green.
Assignee: nobody → continuation
Per bug 1325148 comment 59, leak checking has been fixed on Aurora without this directory being whitelisted, so it should be unaffected.
Looks pretty green. I guess either it was fixed by one of the other leak fixes that already landed or else the failure I initially saw was an anomaly. I was in a bit of a hurry trying to catch and file everything so probably jumped the gun on this one.

Even if it is intermittent, I think we can re-enable checking and treat it like a normal intermittent (while filing a new bug that actually matches the failure signature). So I agree, let's just re-enable checking here and close this bug out.
This is just your patch but I'll just deal with landing it...
Comment on attachment 8824509 [details]
Bug 1325277 - Re-enable leak checking for dom/animation/test/css-animations.

https://reviewboard.mozilla.org/r/102974/#review103538

Thanks!
Attachment #8824509 - Flags: review?(ahalberstadt) → review+
Pushed by amccreight@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7503c1720aa7
Re-enable leak checking for dom/animation/test/css-animations. r=ahal
https://hg.mozilla.org/mozilla-central/rev/7503c1720aa7
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
You need to log in before you can comment on or make changes to this bug.