Login Button Does Not Show Up

RESOLVED WORKSFORME

Status

()

Core
Layout: Tables
--
minor
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: vossman, Assigned: karnaze (gone))

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
The page calls the command:
document.writeln('<input class=buttontext type=submit tabindex="3" value="Access
Cardmember Central">');

and no button shows up
(Reporter)

Comment 1

16 years ago
Java settings:
[X] Navigator
[ ] Mail & Newsgroups

Allow webpages to:
[ ] Open Urequested Windows
[ ] Open a link in a new window
[X] move or rezie existing windows
[ ] Raise or lower windows
[ ] Change status bar text
[X] Change images
[X] Create or change cookies
[X] Read cookies

Comment 2

16 years ago
This is not a Java problem, but a browser problem. Reassigning
to Browser-General component until we can find out more information.
This is not a JS Engine issue -

vossman77@yahoo.com: what build ID are you using? I see the login
button "Access Cardmember Central" just fine with Mozilla trunk binary 
20020317xx on WinNT and 200203124xx on Mac9.1.

Could you also try the site with all your JavaScript options switched
to "yes" (i.e. all checked). That will help pin this down. Also, if you
get a chance, try the site on another OS, to see if this is OS-specific.

Repeating, this site WORKSFORME -
Assignee: nboyd → asa
Component: Core → Browser-General
Product: Rhino → Browser
QA Contact: pschwartau → doronr
(Reporter)

Comment 3

16 years ago
I was using the latest nightly build: 2002032008

I just checked using the 0.9.9 release it WORKS FOR ME: 2002031005

But it is still a recurring problem in that new build.

vossman
(Reporter)

Comment 4

16 years ago
I recently downloaded build 2002032113 and the problem is still there. There is
no button whatsoever only a blank space where it should be.

This wouldn't be a conflict with any plugin I have installed would it?

list of plugins:

QuickTime Plugin.plugin
MRJPlugin.policy
MRJPlugin.jar
Windows Media Plugin
NPSVG3Carbon
NPSVG3.zip
Shockwave Flash NP-PPC
PluginLib
NPSVG3ReadMe.html
MRJPlugin.properties
MRJPluginCarbon

Comment 5

16 years ago
The part of the table that contains that button is collapsed and invisible. Over
to HTML Tables. 
Assignee: asa → karnaze
Component: Browser-General → HTMLTables
QA Contact: doronr → amar

Comment 6

16 years ago
I have the same problem, running the CVS Mozilla checked out last night (Mar.
23, 2002).  All my JavaScript options are on, and I have no plugins installed yet.

I noticed this behavior at
http://www.linuxnewbie.org/cgi-bin/ubbcgi/ultimatebb.cgi first (there should be
light bulbs in the left column by the forum names; these should be the "on"
image if there have been new posts since last time you were there, and the "off"
image if there have been no new posts.  What happens is that nothing appears at
all), but after searching bugzilla and finding this, the same symptoms occur on
that accountonline page also.

With the Linuxnewbie site, when I open the DOM Inspector and load that URL, it
does show the correct tags (the IMG tags do get inserted as far as it can tell
is what that tells me... but I could be wrong) in the "tree" in the upper-left
area of the DOM Inspector window, but the images still don't appear in the lower
half of the window (the actual rendering area).

I'm running Linux From Scratch 3.0 and XFree 4.2, and it happens in both KDE
2.2.2 and twm.

It did work in my old installation of Mozilla, which was a CVS pull slightly
after 0.9.8's release.

Comment 7

16 years ago
I'm seeing this as well on Win2K Build ID 2002032503. This is a recent bug, as
this wasn't a problem for me about a week ago. 

Personally, I would find the severity more than Minor for this issue since it
keeps me from using the browser for one of my primary activities. Not being able
to log in to check my credit card statements is a really big deal for me.

Comment 8

16 years ago
 Sean Kendall Schneyer: If you really care about this, isn't that the right time
to create a minimal testcase?? http://www.mozilla.org/newlayout/bugathon.html

Comment 9

16 years ago
Created attachment 76249 [details]
testcase (no tables)

This test case clearly shows that the <input> button inserted with Javascript
(document.writeln) does not appear but the one inserted directly in the html
does. Please note that no tables are used in this testcase, so this actually
has nothing to do with HTML Tables as suggested in comment #5, by Asa.
Okay, I just downloaded the latest build (2002032603) and this problem seems to
have gone away. Both accountonline.com and my attached testcase are working for
me on Win2K.

Comment 11

16 years ago
WFM in Linux 2002032608.

Someone mark this bug as WFM or better still mark it as a dup of the bug whose
fix fixed this bug too. 

Platform/OS should really be All/All

Comment 12

16 years ago
Searched around and found bug 132673. I'm pretty sure this bug got fixed because
of patch to 132673. Someone confirm and mark it as dup.

Comment 13

16 years ago
This bug is fixed. It got fixed because of fix to bug 132673 (or so I believe).
Someone please mark this as fixed or mark it as a dup of 132673

Comment 14

16 years ago
wfm win98 2002041203+ comments
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.