Warning/Severe badge on download button positioned out of the button in RTL mode

RESOLVED WORKSFORME

Status

()

Firefox
Downloads Panel
RESOLVED WORKSFORME
2 years ago
a year ago

People

(Reporter: rexboy, Assigned: tomer)

Tracking

({good-first-bug})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

STR:
1. Switch to RTL mode
2. open http://testsafebrowsing.appspot.com
3. download a test malicious file

Expected:
The red badge is shown on appropriate position on left-top of the arrow in the download button.

Actual:
The red badge exceeds the button at the left side.

We should just need to change the margin-right to margin-inline-end for the badge.
(Assignee)

Comment 1

2 years ago
It's a regression caused by a recent fix to the about:config page. I have a patch ready to be applied.

https://bugzilla.mozilla.org/attachment.cgi?id=8822099
Assignee: nobody → tomer.moz.bugs
Status: NEW → ASSIGNED
(Assignee)

Updated

2 years ago
Depends on: 1325883

Comment 2

a year ago
Tomer, is this fixed by bug 1325883? The patch doesn't seem related.
Flags: needinfo?(tomer.moz.bugs)
(Assignee)

Comment 3

a year ago
Created attachment 8832407 [details]
screenshot

I think it does work as expected at the moment.
Flags: needinfo?(tomer.moz.bugs)

Updated

a year ago
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.