New dashboard at HSBC UK is not displayed

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: geobert, Unassigned)

Tracking

({regression})

53 Branch
regression
Points:
---

Firefox Tracking Flags

(firefox51 unaffected, firefox52 affected, firefox53 unaffected, firefox54 unaffected)

Details

(URL)

Attachments

(1 attachment, 2 obsolete attachments)

2.03 KB, application/x-zip-compressed
Details
(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20161221030226

Steps to reproduce:

Log in to the new HSBC UK web dashboard.


Actual results:

I can briefly see the dashboard and then it disappear, leaving the page only with the HSBC background and some top menu.


Expected results:

The account listing should stay. Happens with Aurora 52 as well (22/12 build).

Working fine on Beta 51.

Comment 1

2 years ago
Link to the HSBC dashboard, please.
Flags: needinfo?(geobert)
(Reporter)

Comment 2

2 years ago
Sorry for this
https://www.services.online-banking.hsbc.co.uk/

(obviously, you need an account at HSBC to access this)

Comment 3

2 years ago
Hello Geobert, Thanks for this report. I couldn't test this one as I don't have an account with HSBC. May I request you to retest this issue with fresh profile and safe mode. Let us know your finding.
(Reporter)

Comment 4

2 years ago
Just done it with 53.0a1 (2016-12-27) (64-bit)

New profile no safe mode
New profile WITH safe mode

same bug

Comment 5

2 years ago
Thanks for retesting! I have not been able to duplicate this issue due to unavailability of an HSBC account. If this HSBC dashboard page doesn't contain your personal information, may I request you to save the page locally using "Right Click -> Save Page As -> Web Page, Complete" and attach the zipped file with this bug so that we can start looking into it. Please let us know in case you do not feel comfortable with this approach. In that case we will have to find some alternate route, which may take some time.
(Reporter)

Comment 6

2 years ago
I will try to anonymise any sensible info.
(Reporter)

Comment 7

2 years ago
Created attachment 8823587 [details]
hsbc bug.zip

here it is, 2 versions because I found out that the entire disapearing section is not in the file where the bug occurs. so I've load the page in 50 and anonymise personal stuff for comparaison.

good luck guys

Comment 8

2 years ago
Hello Andrew, can you please ask someone to look into this. Breaking HSBC is bad enough to investigate.
Component: Untriaged → DOM
Flags: needinfo?(overholt)
Product: Firefox → Core
Without trying too hard, the saved page doesn't load for me (I'll try more later; keeping needinfo).
In other news, Anne said he has an HSBC account and he'll try to reproduce so I'm needinfo'ing him.
Flags: needinfo?(overholt) → needinfo?(annevk)
Flags: needinfo?(overholt)

Comment 10

2 years ago
I tried too, and I doubt the testcase is working. Both pages don't load in F50 or 53, even in very older versions.
For me too, both pages don't load either on Fx 50 or 53 but they do load on IE, and I can see the difference between two pages.
Anne tried and told me on IRC that there are a bunch of errors in the console and there may be something related to the version of dojo they're using (https://dojotoolkit.org/). He said he could try to compare with Chrome and get back to us.

Karl or Mike, do you know anyone at HSBC that presumably will have an account and be able to see what's up here?
Flags: needinfo?(overholt)
Flags: needinfo?(miket)
Flags: needinfo?(kdubost)
(Reporter)

Comment 13

2 years ago
Please note it has to do with the new dashboard deployed a month ago in UK. I don't know about other countries (as far as I know, France does not have it)
I don't have any contacts at HSBC, sorry. But if Anne can provide the console errors (or the original reporter), that would be super helpful.
Flags: needinfo?(miket)
(Reporter)

Comment 15

2 years ago
how do I save the console log? I have things interesting here (error in dojo)

Comment 16

2 years ago
Right click the logs in the console, there is an option to select logs and copy them.
(Reporter)

Comment 17

2 years ago
Created attachment 8824572 [details]
hsbc bug log.zip

Had to click and drag to select the logs, no menu on right click (using nightly 53.0a1 (2017-01-06) (64-bit))

Comment 18

2 years ago
Bug 567432 is possibly related? (I similarly get a bunch of dojo.js errors and they are different from the errors I get with Chrome, but no real smoking gun among those errors regarding a feature we don't support (or do) or something like that.)

According to https://www.hsbc.co.uk/1/2/accessibility#online-banking3 Firefox is a supported browser, so hopefully this gets fixed soon. I tried to contact them through the feedback form, alerting them of the problem.
Flags: needinfo?(annevk)
It works on Firefox stable.

It doesn't work on Nightly, with or without content tracking protection enabled, and with or without uBlock enabled. I was also unable to make it work with Chrome stable-got the same "spinning loader wheel" dashboard symptom.

Their support team advised me to
- disable ad blockers
- disable antivirus (?)

This was happening on two different Mac OS computers.
If it works in Release but not on Nightly, then regression-range, please.
Olli: I do not understand exactly what you mean with 'regression-range', but as far as I can tell I have been unable to use the new interface with Nightly (which is my usual browser) since mid November 2016, when it started to be rolled to users.
If the page works with FF release version, I assume it works with some old Nightlies too.
What is the first Nightly it doesn't work with?

But if it doesn't work even using old Nightlies (pre 2016-08-01, when FF50 merged from nightly to aurora), then there is something else happening.
(Reporter)

Comment 24

2 years ago
I'm looking for the regression range
I tested with the Nightly from the 31 of July, and it doesn't work - same issue as the current Nightlies. The dashboard with the list of accounts is briefly flashed on the screen and then disappears

This is the version I used: https://archive.mozilla.org/pub/firefox/nightly/2016/07/2016-07-31-03-02-03-mozilla-central-l10n/

Is this correct? Should I try even earlier versions? Which strategy do people follow for regression ranges?
I tried a few more things with my Stable Firefox which actually hadn't been updated in a while, so I kept accepting the updates and testing each time a new update came:

Fx 47 works
Fx 48.0.2 works
Fx 50.1.0 (stable) works

... which is confusing because the other Nightly I downloaded in the previous comment was also Fx 50 but didn't work.

I'm using empty profiles for these tests.
(Reporter)

Comment 27

2 years ago
02-Nov-2016 KO
01-Sep-2016 KO
01-Aug-2016 32 bits KO
01-Jul-2016 KO
01-Jun-2016 KO

I'm… confused
I suspect it's not a regression from us; they are doing some sort of bogus version detection. Although simple UA spoofing didn't seem to fix it either.

Gerv
And why not try DevEdition too, you might ask...?

Firefox Developer Edition 52.0a2 2016-12-01: does NOT work (dashboard flashes then all accounts disappear again)
Firefox Developer Edition 52.0a2 2016-12-12: does NOT work
Firefox Developer Edition 52.0a2 2017-01-20: does NOT work

again using a new profile for these tests
I'm quite convinced their JS is in a deplorable state, since the dashboard also failed to load in Chrome at some point. I feel like this would involve a closer look at their dashboard code, but I am not sure how these things are handled with webcompat etc - if we find the issue do we just tell them? Will they actually fix it? etc
This is *so bizarre* --- I just accessed my account but with the latest Nightly, using my normal profile which used to result on the empty dashboard symptom, with the intention of debugging their JS... and... it worked O_O

So: Fx Nightly 53.0a1 (2017-01-20) = Works
(Reporter)

Comment 32

2 years ago
Aurora 20/01 KO

but I confirm, fresh profile, Nightly 20/01 OK
(Reporter)

Comment 33

2 years ago
Nightly 19/01 OK as well
Yes, working for me on Nightly too. But still not working on Aurora, which means that there will be a window of non-functionality on Release before too long if we don't track this down, which would suck.

Gerv
(Reporter)

Comment 35

2 years ago
build from 17th is broken
build from 18th works

Hope this help
Geobert: are you talking about nightly builds, or some other builds? And do you mean the 17th and 18th of January? Can you provide the exact build IDs?

Gerv
Can you use mozregression? It will tell us exactly what broke it.

http://mozilla.github.io/mozregression/
You can launch this command:

mozregression --good 2017-01-18 --bad 2017-01-17 --find-fix

It will download and let you test a few builds, and then it till tell you what fixed the bug.
(Reporter)

Comment 41

2 years ago
complete bisection info if ever needed:

app_name: firefox
build_date: 2017-01-17 07:03:32.952000
build_file: C:\Users\GQ185008\.mozilla\mozregression\persist\14a12ac05a4b--mozilla-inbound--firefox-53.0a1.en-US.win64.zip
build_type: inbound
build_url: https://queue.taskcluster.net/v1/task/WAMPbnD5RkOJYIN5___JHA/runs/0/artifacts/public%2Fbuild%2Ffirefox-53.0a1.en-US.win64.zip
changeset: 14a12ac05a4b9dddeb6919540ab05af08e730912
pushlog_url: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=f81835544ab8e371a6d59a609a88567fce2183f5&tochange=14a12ac05a4b9dddeb6919540ab05af08e730912
repo_name: mozilla-inbound
repo_url: https://hg.mozilla.org/integration/mozilla-inbound
task_id: WAMPbnD5RkOJYIN5___JHA

Comment 42

2 years ago
Probably due to bug 1269155 flagged for web compatibility issues.

Updated

2 years ago
Blocks: 1269155
status-firefox51: --- → unaffected
status-firefox52: --- → unaffected
status-firefox53: --- → affected
status-firefox54: --- → affected
Keywords: regression
Loic, that is what fixed the bug.
No longer blocks: 1269155
status-firefox52: unaffected → affected
status-firefox54: affected → unaffected
Depends on: 1269155
It landed on 53, so 53 is now unaffected.
status-firefox53: affected → unaffected
Status: UNCONFIRMED → NEW
Ever confirmed: true
Thanks for the info Geobert.

Would you be able to run a second test to find what broke the site between 51 and 52?

The command this time would be:

mozregression --good 2016-08-01 --bad 2016-11-13

This way we can evaluate if it's better to backout the patch that caused this regression, or uplift the patch that fixed it.
(Reporter)

Comment 46

2 years ago
I will do it at home, if ok (still at work ;) )

Is there anyway to delete the attachments? (I tried to anonymise and remove any personal info, but we never know…)
The content of attachment 8823587 [details] has been deleted for the following reason:

per request of marco
The content of attachment 8824572 [details] has been deleted for the following reason:

per request of marco
(Reporter)

Comment 49

2 years ago
Found some time to run the test : the bisection failed :-/
Can you save the output to a file and attach it here?
(Reporter)

Comment 51

2 years ago
Created attachment 8833294 [details]
failed_bisection.zip

I'm using gui version of mozregression
The regression range found doesn't contain anything that looks related: https://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2016-08-01&enddate=2016-08-02.

I'm starting to wonder if the bug is intermittent.

Sole and/or Gerv, can you try finding a regression range too? Perhaps both with "mozregression --good 2017-01-18 --bad 2017-01-17 --find-fix" to find the fix in 53 and with "mozregression --good 2016-08-01 --bad 2016-11-13" to find the cause in 52.
Flags: needinfo?(sole)
Flags: needinfo?(gerv)
Hi, sorry, I'm a bit confused. Is the site currently broken in Beta 52, in addition to dev edition and nightly?
Comment hidden (obsolete)
Apparently the site is broken only in Beta now. It was broken in 52 Aurora and not broken in 53 Nightly, so now it's broken in 52 Beta and not broken in 53 Aurora.
The preference to enable rootNode was only ever enabled on Nightly/Aurora (bug 1270387), so this bug is basically worksforme now. The HSBC dashboard should now be working on all Firefox versions.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(sole)
Flags: needinfo?(gerv)
Flags: needinfo?(geobert)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.