Turkish characters in form entry is shown incorrectly

VERIFIED INVALID

Status

()

Core
Internationalization
--
major
VERIFIED INVALID
16 years ago
16 years ago

People

(Reporter: Ahmet A. Akin, Assigned: Roy Yokoyama)

Tracking

({intl})

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
For producing:
Go to Google, 
write "tIrtIl Seker" (Not, you may need a turkish keyboard letters "I" in
"tIrtIl" is actually "i" without point, letter "S" in "Seker" is actually a "s"
with a point down, read as "sh") in the search form area.

When the result are come you see the search words as "tırtıl
şeker" in search form area.

i believe it is releated with Bug 117422

Char set: ISO8859-1
Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.9+) Gecko/20020319

Comment 1

16 years ago
Ahmet, If you try the same thing on IE (Encoding : Western ISO)  you get the
same result, I guess the reason is, if you submit Turkish character on a web
site with default encoding is non-Turkish you get converted characters.
 So, first change your encoding to Turkish then submit the form, you will get
the correct result.
But I dont know whether this behaviour is correct. Should this bug be marked as
"invalid" ?? 
Summary: Turkish characters in form entry is shown incorrectly → Turkish characters in form entry is shown incorrectly

Comment 2

16 years ago
And another point is , if you do such a search in google, it does the correct
search, you just lost the characters if encoding is non-turkish. 
-> INT
Assignee: asa → yokoyama
Component: Browser-General → Internationalization
QA Contact: doronr → ruixu

Updated

16 years ago
Keywords: intl
QA Contact: ruixu → ylong

Comment 4

16 years ago
Very similar with bug 125034, but that one is linux only.

cc Shanjian.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

16 years ago
there are no such turkish characters in ISO-8859-1, change it to ISO-8859-9 and
you should be able to work 
mark this as invalid. this is a user error
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 6

16 years ago
Marking as verified per comment above.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.