[__NSDictionaryM UTF8String]: unrecognized selector crash when changing folder (Mac 10.12 sierra)

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
2 years ago
23 days ago

People

(Reporter: patrick, Unassigned)

Tracking

({crash, regression})

52 Branch
x86_64
Mac OS X
crash, regression
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird52? affected, thunderbird53 unaffected)

Details

(Reporter)

Description

2 years ago
Using Aurora 52.0a2 (2016-12-22) (64-bit) on macOS 10.12.2.

Whenever I try to change to a local folder, Thunderbird crahses. For unknown reasons, the crash reporter is unable to create a crash report (it crashes as well), but on the command line I see the following error messages:

2016-12-23 08:13:01.123 thunderbird-bin[53959:1199182] -[__NSDictionaryM UTF8String]: unrecognized selector sent to instance 0x7fb0cf4de370
2016-12-23 08:13:01.128 thunderbird-bin[53959:1199182] Mozilla has caught an Obj-C exception [NSInvalidArgumentException: -[__NSDictionaryM UTF8String]: unrecognized selector sent to instance 0x7fb0cf4de370]
CoreData: warning: dynamic accessors failed to find @property implementation for 'serialNumber' for entity ABCDAddressBookSource while resolving selector 'serialNumber' on class 'ABCDAddressBookSource'.  Did you remember to declare it @dynamic or @synthesized in the @implementation ?
*** Blocklist::notify: Requesting https://blocklist.addons.mozilla.org/blocklist/3/%7B3550f703-e582-4d05-9a08-453d09bdfdc6%7D/52.0a2/Thunderbird/20161222004022/Darwin_x86_64-gcc3-u-i386-x86_64/en-US/aurora/Darwin%2016.3.0/default/default/1/301/1/
The process has forked and you cannot use this CoreFoundation functionality safely. You MUST exec().
Break on __THE_PROCESS_HAS_FORKED_AND_YOU_CANNOT_USE_THIS_COREFOUNDATION_FUNCTIONALITY___YOU_MUST_EXEC__() to debug.
[the last message repeats for many times]

The crash happens in safe-mode as well as in normal mode.
We need to figure this out ASAP...

Sounds like startup crash bug 1310814.  Which perhaps correlates to 51.0a2 startup crash signature  js::NativeGetProperty, BUT which doesn't exist in 52.0a2 - https://crash-stats.mozilla.com/signature/?product=Thunderbird&release_channel=aurora&platform=Mac%20OS%20X&signature=js%3A%3ANativeGetProperty&date=%3E%3D2016-11-23T08%3A29%3A45.000Z&date=%3C2016-12-23T08%3A29%3A45.000Z&_columns=date&_columns=product&_columns=version&_columns=build_id&_columns=platform&_columns=reason&_columns=address&_sort=-date&page=1 like bp-8b7dd606-fc15-4f80-ad15-8451f2161212

I think Patrick's lack of Mozilla crash report is a symptom which explains why there are no Mac reports on crash-stats for 52.0a2 https://crash-stats.mozilla.com/topcrashers/?product=Thunderbird&version=52.0a2&days=14 !

Patrick is this a new Mac with the touch bar?
Flags: needinfo?(patrick)
Keywords: crash
Summary: Crash when changing folder → [__NSDictionaryM UTF8String]: unrecognized selector crash when changing folder
(Reporter)

Comment 2

2 years ago
No, it's a MacBook Pro 13" Retina model Mid 2014.
(Reporter)

Updated

2 years ago
Flags: needinfo?(patrick)

Comment 3

2 years ago
Sadly I'm unable to reproduce. I'm using TB 52.0 on my new MacBook Pro on macOS 10.12.2 now for some time, but did not see any crash at all. I've tried with Aurora 52.0a2 (2016-12-22), but changing to a local folder worked fine for me. But I need to say, there was just one mail in my local folder. Maybe the crash happens if you have more than xy mails in the local folder or if the mail has any special encoding?
(Reporter)

Comment 4

2 years ago
I just noticed that I didn't start Aurora correctly. I directly invoked thunderbird-bin, instead of opening the app using the "open" command (which seems to do something different).

I'll observe this for a while to see if I still get any crashes.
Severity: critical → minor
nomis, patrick,
what happens if you install nightly tester tools and force crash?  Do you get Mozilla crash reporter?

Comment 6

2 years ago
How to force a crash?
install https://addons.mozilla.org/en-us/thunderbird/addon/nightly-tester-tools/ then tools | nightly ... | crash me! | divide by zero
(Reporter)

Comment 8

2 years ago
Forcing a crash leads to a Crash Reporter dialog saying that the application crashed, but:

"Unfortunately, the crash reporter is unable to submit a report for the crash. 

Details: the application  didn't leave an application data file"
Eckhard, do you get something similar?
Flags: needinfo?(e.berberich)

Comment 10

2 years ago
(In reply to Patrick Brunschwig from comment #8)
> Forcing a crash leads to a Crash Reporter dialog saying that the application
> crashed, but:
> 
> "Unfortunately, the crash reporter is unable to submit a report for the
> crash. 
> 
> Details: the application  didn't leave an application data file"

Same here. Also forcing the application to crash by sending a "segmentation violation" signal to Earlybird did not produce any crash report (apart from the Apple own one).

Comment 11

2 years ago
Same results here as in comments #8 and #10 when forcing a crash.
(iMac 21.5" Retina 4K, late 2015, macOS 10.11.6)
Flags: needinfo?(e.berberich)
Ted does comment 10 sound familiar?  Multiple versions of macOS and models (not just the new mac).
In fact, afaict we are getting zero Mac crash reports for Thunderbird aurora 52.0a2 (comment 1). 

Ed or Nomis, does nightly 53.0a1 also produce no crash report?
https://crash-stats.mozilla.com/topcrashers/?platform=Mac%20OS%20X&product=Thunderbird&version=53.0a1&days=14 shows a few, so I'm hoping it works for you
Flags: needinfo?(ted)

Comment 13

2 years ago
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #12)

> Ed or Nomis, does nightly 53.0a1 also produce no crash report?
> https://crash-stats.mozilla.com/topcrashers/
> ?platform=Mac%20OS%20X&product=Thunderbird&version=53.0a1&days=14 shows a
> few, so I'm hoping it works for you

Interestingly, yes. 53.0a1 gives me a crash report. Same procedure like before, for 52.0a2.
I don't know if this is a "real" regrssion, but let's treat it as such until we know otherwise.
And the lack of crash report, which may be a different bug, is definitely a blocker for version 52.
Severity: minor → normal
status-thunderbird52: --- → affected
status-thunderbird53: --- → unaffected
tracking-thunderbird52: --- → ?
Keywords: regression
No ted :(

FWIW, crash reporter is known to crash for sierra - Bug 1324424 - which apparently won't be resolved without an update to MacOS 10.12.3 - which, huzza!, just became available https://techcrunch.com/2017/01/23/apple-releases-macos-10123-with-macbook-pro-gpu-and-battery-fixes/

You might update and see what happens.
Severity: normal → critical
Flags: needinfo?(ted)
Sounds like it might be related to the issues in bug 1320048. Supposedly we need to update the SDK we build with.
(Reporter)

Comment 17

2 years ago
Yes, this looks like bug 1320048.  

Now that the crash reporter works again on Aurora, I get the following crash ID: bf7e12a9-40c3-42f0-a60e-245fd2170124

(I just upgraded to Sierra 10.12.3)
(In reply to Patrick Brunschwig from comment #17)
> Yes, this looks like bug 1320048.  
> 
> Now that the crash reporter works again on Aurora, I get the following crash
> ID: bf7e12a9-40c3-42f0-a60e-245fd2170124

that would be bp-bf7e12a9-40c3-42f0-a60e-245fd2170124 :)
@  libsystem_kernel.dylib@0x19dd6 
so bug 1286613
Summary: [__NSDictionaryM UTF8String]: unrecognized selector crash when changing folder → [__NSDictionaryM UTF8String]: unrecognized selector crash when changing folder (Mac 10.12 sierra)

Comment 19

2 years ago
Hey Folks, I'm getting this error in my console and immdediate crash on launch for any versions newer than 50.0b3 with El Cap 10.11.6 on a 2010 MacMini (4,1).  I've sent in a bunch of crash logs from the automated crash reporter.  If you want me to try anything let me know.

Updated

2 years ago
Blocks: 1313774
(In reply to mychailo from comment #19)
> Hey Folks, I'm getting this error in my console and immdediate crash on
> launch for any versions newer than 50.0b3 with El Cap 10.11.6 on a 2010
> MacMini (4,1).  I've sent in a bunch of crash logs from the automated crash
> reporter.  If you want me to try anything let me know.

mychailo, I see only bp-cd7c4073-2ede-4f45-ab4f-ce22b0170603. Are you still able to reproduce this crash?
Depends on: 1324892
Flags: needinfo?(mychailo)
(In reply to Ted Mielczarek [:ted.mielczarek] from comment #16)
> Sounds like it might be related to the issues in bug 1320048. Supposedly we
> need to update the SDK we build with.

Ted, do you mean Bug 1324892 10.11 SDK?  OR bug 1391023 10.12 SDK?
Flags: needinfo?(ted)
Nomis101, patrick, are you still able to reproduce using the steps of comment 0, or other steps?

It's disturbing that some Mac crashes are not being reported. I've recently been seeing reports of this in SUMO.
Flags: needinfo?(patrick)
Flags: needinfo?(Nomis101)
(Reporter)

Comment 23

a year ago
No, I haven't seen this for quite a while.
Flags: needinfo?(patrick)

Comment 24

a year ago
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #20)
> (In reply to mychailo from comment #19)
> > Hey Folks, I'm getting this error in my console and immdediate crash on
> > launch for any versions newer than 50.0b3 with El Cap 10.11.6 on a 2010
> > MacMini (4,1).  I've sent in a bunch of crash logs from the automated crash
> > reporter.  If you want me to try anything let me know.
> 
> mychailo, I see only bp-cd7c4073-2ede-4f45-ab4f-ce22b0170603. Are you still
> able to reproduce this crash?

Wayne, I am running the newest betas as soon as they become available and have been crash-free for quite a while now.  I think that the crashes stopped in later builds of v53.  If there is a series of steps you'd like me to try to cause a crash, or if you want me to step through a series of builds, let me know.
Flags: needinfo?(mychailo)

Comment 25

a year ago
(In reply to Patrick Brunschwig from comment #23)
> No, I haven't seen this for quite a while.

Me too.
Flags: needinfo?(Nomis101)

Comment 26

a year ago
Don't know where to put this, but 56.0b3 is crashing frequently on my Win10 64 bit box. I think I'm submitting crash reports, but the crash reporter may not actually be working.  My log says 8 submitted this month including 3 today, but they are 1kb. Crash happens when I open an unread mail in Inbox. After restart, the mail shows as read and I can continue opening and reading mail. If the crash reporter is not working, then that might be the first thing to fix?
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #21)
> Ted, do you mean Bug 1324892 10.11 SDK?  OR bug 1391023 10.12 SDK?

Sorry, I don't know precisely which SDK will fix this.
Flags: needinfo?(ted)
Based on previous  comments let's call this WFM
Status: NEW → RESOLVED
Last Resolved: 23 days ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.