[Linux] Unable to mute Flash v24 on Linux

RESOLVED WORKSFORME

Status

P2
normal
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: pauly, Assigned: benjamin)

Tracking

unspecified
All
Linux

Firefox Tracking Flags

(firefox50 affected, firefox51 affected, firefox52 affected, firefox53 affected)

Details

(Reporter)

Description

2 years ago
[Note]:
- Linux only

[Affected versions]:
- 50.1.0, 51b10, 53.0a1 (2016-12-22)

[Affected platforms]:
- Ubuntu 16.04

[Steps to reproduce]:
1. Open http://miniclip.com/games/bug-on-a-wire/en/
2. Click on the screen to start the game
3. Click on the tab sound indicator to mute the sound

[Expected result]:
- Sound is muted and the icon reflects that properly

[Actual result]:
- The icon is displayed as muted, but the sound is still ON

[Regression range]:
- reproduced on FX 47
I'm not sure if the tab sound indicator on Flash pages has ever worked on Linux.
(Assignee)

Updated

2 years ago
Component: Tabbed Browser → Plug-ins
Priority: -- → P3
Product: Firefox → Core

Updated

2 years ago
Duplicate of this bug: 1330195
Can someone help to look into this issue? This is a serious problem.
Duplicate of this bug: 1332371

Comment 4

2 years ago
Same problem here on FF 50.1.0 + Flash 24r0!
(Assignee)

Comment 5

2 years ago
Prior to the recent update, Flash 11 for Linux didn't support the audio notifications at all.

After the update to Flash 24, it appears that Flash now sends audio notifications to Firefox, but doesn't mute when we ask it to. This is almost certainly an Adobe issue and I've raised it with our partner engineers.
Component: Plug-ins → Flash (Adobe)
Product: Core → External Software Affecting Firefox
Version: 51 Branch → unspecified

Comment 6

2 years ago
I've opened an enhancement request for this.  The bug is FLASH-4187266

Comment 7

2 years ago
After further investigation, we've observed a difference in behavior with Firefox on Linux vs other platforms. 

Here's the analysis from our engineer:

To control mute/unmute, Firefox passes "NPNVmuteAudioBool" to plugin via "NPP_SetValue", this works well on Windows, but on Linux, flash player never receives "NPNVmuteAudioBool" from "NPP_SetValue", so I think this is a bug of Firefox Linux.
(Assignee)

Comment 8

2 years ago
I'm debugging.
Assignee: nobody → benjamin
Priority: P3 → P2
(Assignee)

Comment 9

2 years ago
Jeromie, here's what I've found: it appears that when Firefox calls NP_GetEntryPointsFunc on Linux, Flash fills in the NPPluginFuncs structure but setvalue (NPP_SetValue) remains null:

http://searchfox.org/mozilla-central/rev/e95e4ed8b5229a29dacc32c0b90968df5e7a6ff3/dom/plugins/base/npfunctions.h#117

So you are not receiving any NPP_SetValue functions from the browser (on Linux), which probably breaks all of the following features:

* private browsing notifications
* audio muting
* CSS zoom notifications

I think it's likely that you've coded a NPP_SetValue but just haven't included it in the glue code that sets up the initial structure.
Flags: needinfo?(jeclark)

Comment 10

2 years ago
Great, thanks for the insight.  I've kicked this bug back with your input.
Flags: needinfo?(jeclark)

Comment 11

2 years ago
Today I got the update for flashplugin.
Muting on Antergos is now working. 


13:12:18 ~$ pacman -Qs flashplugin
local/flashplugin 25.0.0.127-1
    Adobe Flash Player

Updated

2 years ago
Duplicate of this bug: 1349201
(Assignee)

Comment 13

2 years ago
We believe that this was fixed (on Linux) in the most recent Flash release. Please reopen if you're still seeing this with Flash 25.0.0.127 or later.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.