Can't see scroll bar for network panel when the width is less than 1000px

RESOLVED DUPLICATE of bug 1309826

Status

RESOLVED DUPLICATE of bug 1309826
2 years ago
3 months ago

People

(Reporter: human.peng, Unassigned)

Tracking

({regression})

Trunk
regression
Dependency tree / graph

Firefox Tracking Flags

(firefox52 unaffected, firefox53 wontfix, firefox54 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.28 Safari/537.36

Steps to reproduce:

See screenshot:

No scrollbar: http://i.imgur.com/F3cR07j.png
Has scrollbar: http://i.imgur.com/ooeMBCj.png


Actual results:

It will only show scrollbar when the width is more than around 1000 px.

This to me is very excessive and unnecessary.

Also, why users can't adjust the width of each column?
(Reporter)

Updated

2 years ago
Component: Untriaged → Developer Tools: Netmonitor

Updated

2 years ago
Duplicate of this bug: 1336203
merging information from bug 1336203.

regression range:
  https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9a03728016ff7b76c4850375303e84cce00e4ac4&tochange=28445d6f646be36233d080caae871ed1c39a242d

apparently from bug 1309866.

this issue also happens when the request details is opened and the width becomes small.


also the scroll bar is shown for <1000px situation by following:
  1. make the width >1000px
  2. narrow it slowly

but when I narrow it quickly, the scroll bar goes away.

so, apparently the scrollbar is placed at wrong place.
Blocks: 1309866
status-firefox52: --- → unaffected
status-firefox53: --- → affected
status-firefox54: --- → affected
Keywords: regression
Created attachment 8833062 [details]
scrollbar postion according to boxObject

boxObject says the scrollbar is placed at the red box in the attached screenshot.
apparently, div.request-list-container is wider than div.network-table, and that results in placing the scrollbar outside of visible area.
Thanks for the report!

@Fred, could you please take a look at this?

Honza
Priority: -- → P2
honza: which fred did you want to have take a look?
Flags: needinfo?(odvarko)
(In reply to Randell Jesup [:jesup] from comment #6)
> honza: which fred did you want to have take a look?
Ah, thanks for the note :-)

@Fred, could you please take a look at this?

Honza
Flags: needinfo?(odvarko) → needinfo?(gasolin)

Updated

2 years ago
Assignee: nobody → gasolin
Flags: needinfo?(gasolin)

Updated

2 years ago
Blocks: 1307743
Whiteboard: [netmonitor]

Updated

2 years ago
Flags: qe-verify?
Priority: P2 → --
Whiteboard: [netmonitor] → [netmonitor] [triage]
Btw. There is also bug 1338437 (another scroll-bar issue)

Honza
Flags: qe-verify? → qe-verify+
Priority: -- → P3

Updated

2 years ago
QA Contact: ciprian.georgiu

Comment 9

2 years ago
Ricky, since you are dealing with split bar in Bug 1309183, 
could you help confirm if this issue still happened after applied your patch?
Flags: needinfo?(rchien)

Comment 10

2 years ago
Ooh I get confused, but this bug doesn't related to split bar
Flags: needinfo?(rchien)

Updated

2 years ago
Whiteboard: [netmonitor] [triage] → [netmonitor-reserve]

Comment 11

2 years ago
I found the issue is fixed after convert netmonitor xul to xhtml in Bug 1309826

Updated

2 years ago
Depends on: 1309826

Comment 12

2 years ago
I've tested again and the issue is fixed after bug 1309826 landed
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1309826

Updated

2 years ago
Assignee: gasolin → nobody
No longer blocks: 1307743
Flags: qe-verify+
Priority: P3 → --
QA Contact: ciprian.georgiu
Whiteboard: [netmonitor-reserve]
Fixed in 54 in the duplicate bug but 53 is still affected.
But I don't think we want to uplift the work in bug 1309826 to aurora at this point. 
Is there a smaller fix for this issue you can cherry pick or shall I wontfix it for 53?
status-firefox54: affected → fixed
Flags: needinfo?(rchien)
It would need to uplift a series of patches if we want to fix for 53. I'd prefer to wontfix it for 53 since there is no smaller patch can fix this issue easily.
Flags: needinfo?(rchien)
Great, thanks Ricky!
status-firefox53: affected → wontfix

Updated

3 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.