*Some* Adobe Flash videos fail in Firefox, but okay in Google Chrome

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: mtas22@cox.net, Unassigned)

Tracking

50 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161208153507

Steps to reproduce:

Adobe Flash 
Version 24.0.0.186
 
My system:
Toshiba Laptop running Windows 10 Version 1607 -- all updates current
Windows 64-bit , English , Firefox Version 50.1.0

Go to
http://www.mediaite.com/tv/cnn-guest-cant-contain-his-laughter-at-katrina-piersons-trump-d efense/

Hover mouse cursor over the blank area if video box doesn't appear.


Actual results:

No Video.

Notice if you left click on the play button nothing happens.

But this video works with Google Chrome.

Same with first video displayed on this web page.

http://www.mediaite.com/online/dolly-parton-tells-cnns-baldwin-that-trump-and-clinton-are- both-nuts/
(Reporter)

Comment 1

a year ago
You folks are the last resort.

I have reported this to the site where the two videos (there were others) only play in Chrome -- namely Mediaite.

I have also posted a question on the Adobe forum for Flash -- but no reply.

Poor me...sob, sob. :-)

Comment 2

a year ago
Video work for me with FF50 on Win 7.

Are you in private mode with tracking protection enabled?

Could you test with a fresh profile:
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(mtas22)
(Reporter)

Comment 3

a year ago
Thanks Loic for your suggestions. BTW, I am not running FF in private mode with tracking protection enabled.

Do you have access to a computer running Windows 10? (Both my Toshiba laptop and my Dell desktop have this same problem with *some* Adobe Flash videos.)

The reason I ask is none of these efforts made a difference.

• Trying the aforementioned links on two computers -- as I stated.
• Creating a new Firefox Pofile.
• Running Firefox with add-ons disabled.
• Disabling my Norton Security (Smart Firewall and Auto-Protect).
• Disabling Adblock Plus.
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0

I have tested your issue on latest FF release (50.1.0) and latest Nightly build and could not reproduce it. I'm able to play the both videos and can move them to different part of it. 

Could you please retest this using latest Nightly build (https://nightly.mozilla.org/) and report back the results ? When doing this, please use a new clean Firefox profile, maybe even safe mode, to eliminate custom settings as a possible cause (https://goo.gl/PNe90E).
(Reporter)

Comment 5

a year ago
Thank you so much for your help Stephen. As a retiree with free time I was able to spend most of the afternoon trying to isolate this. Unfortunately mot much success.

I tried Firefox Nightly in Safe Mode.

Also tried disabling all the Add-on Extensions and Plug-ins individually. (This was important since my sister is seeing the same issue with the same Dell desktop. A computer I configured with the same Windows 10 settings, Norton AV and Firefox customization.)

I also cleared the entire FF History, cookies and cache.

The only thing that seemed to work with either Firefox Nightly or Firefox Version 50.1.0 was to create a totally new profile. Ugh!

This is not an attractive solution given all the work it would take to restore Firefox to the wait I like it.

Oh well. Wish I could have narrowed it down for you.

Michael T.

Comment 6

a year ago
Firefox Nightly doesn't reproduce.

Comment 7

a year ago
Did you try to reset your current profile?
https://support.mozilla.org/en-US/kb/reset-firefox-to-fix-most-problems

So youcan keep only the private data.
(Reporter)

Comment 8

a year ago
What a great suggestion Loic -- which appears to have helped me solve it. (A problem with Cookies.)

Namely, there have been a handful of embedded Adobe Flash videos (less than 10 on 2 different websites) in recent months that necessitated ed me to switch to Google Chrome (Ugh!) to get them to work.

THE REASON (drum roll please..):
Setting the following at Tools > Options > Privacy
In the section labled HISTORY select "Use custom settings for history."
Then uncheck "Always use private browsing mode"
But check the next three including "Accept cookies from sites."

Now here's the flaw/issue/bug.

For the setting "Accept third-party cookies:" if you change from "Always" to "From visited" you will probably discover the aforementioned videos no longer play (i.e., work) and users with this config/setting would have to use Chrome or possibly Edge with Windows 10.

Please let me know if you find the same...and thank you for the excellent suggestion so I could more easily isolate the cause.

Comment 9

a year ago
It's a common "issue", if some 3rd-party cookies are blocked, some ressources are not available. It appears on many websites with audio/video streaming offered by a 3rd-party (like a CDN).

Sometimes, you have to allow cookies to browse fully the website.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(mtas22)
Resolution: --- → INVALID
(Reporter)

Comment 10

a year ago
Good to know. Thank you for the feedback. I noticed if you block 3rd party videos on Chrome you see the same results as your comment suggests.

I do think it is noteworthy (or at least interesting to me) that I play website embedded Adobe Flash videos all day long (probably 10-20 per day) as a retiree -- and this "3rd party cookies" issue as only reared its ugly head less than 10 times in recent months.

Oh well. Glad it's resolved.

I notified the website Mediaite since they are the biggest offenders -- or perhaps I should say their content providers are the biggest offenders. :-)

Comment 11

a year ago
Yeah, it's up to the final user to make a compromise between security/privacy and user-friendliness for browsing. :)
You need to log in before you can comment on or make changes to this bug.