If link enclosed in B tags is clicked, highlight is wrong

RESOLVED DUPLICATE of bug 65917

Status

()

Core
Layout
P2
major
RESOLVED DUPLICATE of bug 65917
18 years ago
14 years ago

People

(Reporter: cpratt, Assigned: buster)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Build ID: 1999090708
Platform: RH Linux 6 (only, fine on Win32)

To reproduce:
- Launch apprunner
- Load a page with a link (eg mozilla.org)
- Click and hold on the link

Result: Not all of the link is changed to indicate that you are clicking on it.
Only a thin horizontal row of pixels is changed to red, but all of the link
should be changed to red.

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 1

18 years ago
Looks fine for me on NT (the bug doesn't say whether this is a Linux only bug),
and on Kipp's Linux box as well

That's using the latest build
(Reporter)

Updated

18 years ago
Status: RESOLVED → REOPENED
(Reporter)

Updated

18 years ago
Resolution: WORKSFORME → ---
(Reporter)

Comment 2

18 years ago
Reopening and clearing resolution. This is indeed a Linux-only bug; this is
noted by the OS field (which reads Linux) and the "[PP] Linux" in the Summary
field, which means "platform parity (that is, exclusive to one platform) Linux".
(Reporter)

Comment 3

18 years ago
I should also point out that the original bug description reads "RH Linux 6
(only, fine on Win32)".
(Reporter)

Updated

18 years ago
OS: Linux → All
Hardware: PC → All
Summary: [PP] Linux - when link is clicked, it highlights wrong → When link is clicked, it highlights wrong if in B tags
(Reporter)

Comment 4

18 years ago
Actually, it's more complicated than I had originally thought. The link has to
be surrounded by <B> tags. See the above URL or attached test case.

I was also wrong: this is a cross-platform bug. Removing [PP] and changing
platform, etc.
(Reporter)

Comment 5

18 years ago
Created attachment 1609 [details]
Simple test case - m.html - for bug 13258

Updated

18 years ago
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
OS: All → Linux
Hardware: All → PC
Resolution: --- → WORKSFORME
Summary: When link is clicked, it highlights wrong if in B tags → [PP] Linux - when link is clicked, it highlights wrong

Comment 6

18 years ago
As I said in my message when I closed the bug it works fine on Kipp's build on
Linux.
(Reporter)

Comment 7

18 years ago
Does it work fine on Kipp's build using the attached test case or
http://schist/m.html? To reproduce, click and hold on both of the links on that
page. The one without the enclosing B tags works; the one with the enclosing B
tags does not work. I'm using this morning's (19999090808) build. Are you using
a newer build?

I can also reproduce this on phillip's machine.
(Reporter)

Updated

18 years ago
Status: RESOLVED → REOPENED
(Reporter)

Updated

18 years ago
Resolution: WORKSFORME → ---
(Reporter)

Updated

18 years ago
OS: Linux → All
Hardware: PC → All
Summary: [PP] Linux - when link is clicked, it highlights wrong → If link enclosed in B tags is clicked, highlight is wrong
(Reporter)

Comment 8

18 years ago
It also reproduces on kipp's machine using the simplified test case. Honest! :)

Reopening &c.

Updated

18 years ago
Assignee: troy → kipp
Status: REOPENED → NEW

Comment 9

18 years ago
Kipp, sounded like this was your bug

Updated

18 years ago
Severity: normal → major
Status: NEW → ASSIGNED
Priority: P3 → P2
Target Milestone: M11
(Reporter)

Comment 10

18 years ago
This happens in other configurations as well, eg http://schist/smoke or the
Mozilla smoke tests page. There, the pattern is <a><font>foo</font></a>, and the
same problem happens when you click on the link.

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 11

18 years ago
Fixed by my recent updates to line-layout for 4233 and 6865

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 12

18 years ago
With the Sept 13th build, this problem is fixed.

Comment 13

15 years ago
similar bug filed : bug 65917

Comment 14

14 years ago
I think this bug should be reopened. I tried the testcase with Mozilla 1.4
(Gecko/20030624) and current nightly (Gecko/20030718), and the first link still
does not change color on click.

Updated

14 years ago
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 15

14 years ago
This is actually a DUPLICATE and never fixed.

*** This bug has been marked as a duplicate of 65917 ***
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.