Intermittent remoteautomation.py | java-exception java.util.concurrent.TimeoutException: java.io.FileOutputStream.finalize() timed out after 10 seconds at java.lang.Object.wait(Native Method)

RESOLVED DUPLICATE of bug 1313270

Status

()

Firefox for Android
Testing
RESOLVED DUPLICATE of bug 1313270
a year ago
a year ago

People

(Reporter: Treeherder Bug Filer, Assigned: gbrown)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Comment 1

a year ago
[task 2016-12-25T02:22:55.471007Z] 02:22:55     INFO -  12-24 18:20:34.122 E/GeckoCrashHandler(  744): >>> REPORTING UNCAUGHT EXCEPTION FROM THREAD 48 ("FinalizerWatchdogDaemon")
[task 2016-12-25T02:22:55.471326Z] 02:22:55     INFO -  12-24 18:20:34.122 E/GeckoCrashHandler(  744): java.util.concurrent.TimeoutException: java.io.FileOutputStream.finalize() timed out after 10 seconds
[task 2016-12-25T02:22:55.471550Z] 02:22:55     INFO -  12-24 18:20:34.122 E/GeckoCrashHandler(  744): 	at java.lang.Object.wait(Native Method)
[task 2016-12-25T02:22:55.471772Z] 02:22:55     INFO -  12-24 18:20:34.122 E/GeckoCrashHandler(  744): 	at java.lang.Object.wait(Object.java:401)
[task 2016-12-25T02:22:55.472066Z] 02:22:55     INFO -  12-24 18:20:34.122 E/GeckoCrashHandler(  744): 	at java.lang.ref.ReferenceQueue.remove(ReferenceQueue.java:102)
[task 2016-12-25T02:22:55.472323Z] 02:22:55     INFO -  12-24 18:20:34.122 E/GeckoCrashHandler(  744): 	at java.lang.ref.ReferenceQueue.remove(ReferenceQueue.java:73)
[task 2016-12-25T02:22:55.472509Z] 02:22:55     INFO -  12-24 18:20:34.122 E/GeckoCrashHandler(  744): 	at java.lang.Daemons$FinalizerDaemon.run(Daemons.java:170)
[task 2016-12-25T02:22:55.472822Z] 02:22:55     INFO -  12-24 18:20:34.122 E/GeckoCrashHandler(  744): 	at java.lang.Thread.run(Thread.java:841)
[task 2016-12-25T02:22:55.473049Z] 02:22:55     INFO -  12-24 18:20:34.122 E/GeckoCrashHandler(  744): Main thread (1) stack:
[task 2016-12-25T02:22:55.473279Z] 02:22:55     INFO -  12-24 18:20:34.162 E/GeckoLibLoad(  744): Load sqlite start
[task 2016-12-25T02:22:55.473625Z] 02:22:55     INFO -  12-24 18:20:34.162 E/GeckoCrashHandler(  744):     android.graphics.BitmapFactory.nativeDecodeAsset(Native Method)
[task 2016-12-25T02:22:55.473846Z] 02:22:55     INFO -  12-24 18:20:34.172 E/GeckoCrashHandler(  744):     android.graphics.BitmapFactory.decodeStream(BitmapFactory.java:503)
[task 2016-12-25T02:22:55.474107Z] 02:22:55     INFO -  12-24 18:20:34.172 E/GeckoCrashHandler(  744):     android.graphics.BitmapFactory.decodeResourceStream(BitmapFactory.java:356)
[task 2016-12-25T02:22:55.474308Z] 02:22:55     INFO -  12-24 18:20:34.172 E/GeckoCrashHandler(  744):     android.graphics.drawable.Drawable.createFromResourceStream(Drawable.java:800)
[task 2016-12-25T02:22:55.474525Z] 02:22:55     INFO -  12-24 18:20:34.172 E/GeckoCrashHandler(  744):     android.content.res.Resources.loadDrawable(Resources.java:2105)
[task 2016-12-25T02:22:55.474744Z] 02:22:55     INFO -  12-24 18:20:34.172 E/GeckoCrashHandler(  744):     android.content.res.Resources.getDrawable(Resources.java:695)
[task 2016-12-25T02:22:55.475017Z] 02:22:55     INFO -  12-24 18:20:34.172 E/GeckoCrashHandler(  744):     android.widget.EdgeEffect.<init>(EdgeEffect.java:138)
[task 2016-12-25T02:22:55.475177Z] 02:22:55     INFO -  12-24 18:20:34.183 E/GeckoCrashHandler(  744):     org.mozilla.gecko.gfx.OverscrollEdgeEffect.<init>(OverscrollEdgeEffect.java:45)
[task 2016-12-25T02:22:55.475464Z] 02:22:55     INFO -  12-24 18:20:34.183 E/GeckoCrashHandler(  744):     org.mozilla.gecko.gfx.LayerView.<init>(LayerView.java:160)
[task 2016-12-25T02:22:55.475688Z] 02:22:55     INFO -  12-24 18:20:34.202 E/GeckoCrashHandler(  744):     org.mozilla.gecko.gfx.LayerView.<init>(LayerView.java:164)
[task 2016-12-25T02:22:55.475916Z] 02:22:55     INFO -  12-24 18:20:34.202 E/GeckoCrashHandler(  744):     org.mozilla.gecko.GeckoView.<init>(GeckoView.java:115)
[task 2016-12-25T02:22:55.476167Z] 02:22:55     INFO -  12-24 18:20:34.202 E/GeckoCrashHandler(  744):     org.mozilla.gecko.GeckoViewFragment.onCreateView(GeckoViewFragment.java:32)
[task 2016-12-25T02:22:55.476406Z] 02:22:55     INFO -  12-24 18:20:34.202 E/GeckoCrashHandler(  744):     android.support.v4.app.Fragment.performCreateView(Unknown Source)
[task 2016-12-25T02:22:55.476784Z] 02:22:55     INFO -  12-24 18:20:34.202 E/GeckoCrashHandler(  744):     android.support.v4.app.FragmentManagerImpl.moveToState(Unknown Source)
[task 2016-12-25T02:22:55.477165Z] 02:22:55     INFO -  12-24 18:20:34.222 E/GeckoCrashHandler(  744):     android.support.v4.app.FragmentManagerImpl.moveToState(Unknown Source)
[task 2016-12-25T02:22:55.477567Z] 02:22:55     INFO -  12-24 18:20:34.222 E/GeckoCrashHandler(  744):     android.support.v4.app.FragmentManagerImpl.addFragment(Unknown Source)
[task 2016-12-25T02:22:55.477947Z] 02:22:55     INFO -  12-24 18:20:34.222 E/GeckoCrashHandler(  744):     android.support.v4.app.FragmentManagerImpl.onCreateView(Unknown Source)
[task 2016-12-25T02:22:55.478324Z] 02:22:55     INFO -  12-24 18:20:34.222 E/GeckoCrashHandler(  744):     android.support.v4.app.FragmentController.onCreateView(Unknown Source)
[task 2016-12-25T02:22:55.478620Z] 02:22:55     INFO -  12-24 18:20:34.222 E/GeckoCrashHandler(  744):     android.support.v4.app.FragmentActivity.dispatchFragmentsOnCreateView(Unknown Source)
[task 2016-12-25T02:22:55.478838Z] 02:22:55     INFO -  12-24 18:20:34.232 E/GeckoCrashHandler(  744):     android.support.v4.app.BaseFragmentActivityHoneycomb.onCreateView(Unknown Source)
[task 2016-12-25T02:22:55.479042Z] 02:22:55     INFO -  12-24 18:20:34.232 W/ActivityManager(  277): Launch timeout has expired, giving up wake lock!
[task 2016-12-25T02:22:55.479302Z] 02:22:55     INFO -  12-24 18:20:34.232 W/ActivityManager(  277): Activity idle timeout for ActivityRecord{419a69e8 u0 org.mozilla.fennec/org.mozilla.gecko.BrowserApp}
[task 2016-12-25T02:22:55.479585Z] 02:22:55     INFO -  12-24 18:20:34.242 D/AndroidRuntime(  734): Shutting down VM
[task 2016-12-25T02:22:55.479792Z] 02:22:55     INFO -  12-24 18:20:34.263 E/GeckoCrashHandler(  744):     android.support.v4.app.FragmentActivity.onCreateView(Unknown Source)
[task 2016-12-25T02:22:55.480033Z] 02:22:55     INFO -  12-24 18:20:34.282 E/GeckoCrashHandler(  744):     android.view.LayoutInflater.createViewFromTag(LayoutInflater.java:689)
[task 2016-12-25T02:22:55.480253Z] 02:22:55     INFO -  12-24 18:20:34.282 E/GeckoCrashHandler(  744):     android.view.LayoutInflater.rInflate(LayoutInflater.java:755)
[task 2016-12-25T02:22:55.480511Z] 02:22:55     INFO -  12-24 18:20:34.282 E/GeckoCrashHandler(  744):     android.view.LayoutInflater.rInflate(LayoutInflater.java:758)
[task 2016-12-25T02:22:55.480867Z] 02:22:55     INFO -  12-24 18:20:34.292 E/GeckoCrashHandler(  744):     android.view.LayoutInflater.rInflate(LayoutInflater.java:758)
[task 2016-12-25T02:22:55.481117Z] 02:22:55     INFO -  12-24 18:20:34.292 E/GeckoCrashHandler(  744):     android.view.LayoutInflater.inflate(LayoutInflater.java:492)
[task 2016-12-25T02:22:55.481339Z] 02:22:55     INFO -  12-24 18:20:34.292 E/GeckoCrashHandler(  744):     android.view.LayoutInflater.inflate(LayoutInflater.java:397)
[task 2016-12-25T02:22:55.481558Z] 02:22:55     INFO -  12-24 18:20:34.292 E/GeckoCrashHandler(  744):     android.view.LayoutInflater.inflate(LayoutInflater.java:353)
[task 2016-12-25T02:22:55.481813Z] 02:22:55     INFO -  12-24 18:20:34.292 E/GeckoCrashHandler(  744):     android.support.v7.app.AppCompatDelegateImplV7.setContentView(Unknown Source)
[task 2016-12-25T02:22:55.482181Z] 02:22:55     INFO -  12-24 18:20:34.292 E/GeckoCrashHandler(  744):     android.support.v7.app.AppCompatActivity.setContentView(Unknown Source)
[task 2016-12-25T02:22:55.482622Z] 02:22:55     INFO -  12-24 18:20:34.302 E/GeckoCrashHandler(  744):     org.mozilla.gecko.GeckoApp.onCreate(GeckoApp.java:1215)
[task 2016-12-25T02:22:55.482764Z] 02:22:55     INFO -  12-24 18:20:34.302 E/GeckoCrashHandler(  744):     org.mozilla.gecko.BrowserApp.onCreate(BrowserApp.java:611)
[task 2016-12-25T02:22:55.482972Z] 02:22:55     INFO -  12-24 18:20:34.302 E/GeckoCrashHandler(  744):     android.app.Activity.performCreate(Activity.java:5133)
[task 2016-12-25T02:22:55.483253Z] 02:22:55     INFO -  12-24 18:20:34.311 E/GeckoCrashHandler(  744):     android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1087)
[task 2016-12-25T02:22:55.483528Z] 02:22:55     INFO -  12-24 18:20:34.311 E/GeckoCrashHandler(  744):     android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2175)
[task 2016-12-25T02:22:55.483746Z] 02:22:55     INFO -  12-24 18:20:34.311 E/GeckoCrashHandler(  744):     android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2261)
[task 2016-12-25T02:22:55.484027Z] 02:22:55     INFO -  12-24 18:20:34.322 E/GeckoCrashHandler(  744):     android.app.ActivityThread.access$600(ActivityThread.java:141)
[task 2016-12-25T02:22:55.484260Z] 02:22:55     INFO -  12-24 18:20:34.322 E/GeckoCrashHandler(  744):     android.app.ActivityThread$H.handleMessage(ActivityThread.java:1256)
[task 2016-12-25T02:22:55.484545Z] 02:22:55     INFO -  12-24 18:20:34.322 E/GeckoCrashHandler(  744):     android.os.Handler.dispatchMessage(Handler.java:99)
[task 2016-12-25T02:22:55.485021Z] 02:22:55     INFO -  12-24 18:20:34.322 E/GeckoCrashHandler(  744):     android.os.Looper.loop(Looper.java:137)
[task 2016-12-25T02:22:55.485139Z] 02:22:55     INFO -  12-24 18:20:34.322 E/GeckoCrashHandler(  744):     android.app.ActivityThread.main(ActivityThread.java:5103)
[task 2016-12-25T02:22:55.485326Z] 02:22:55     INFO -  12-24 18:20:34.322 E/GeckoCrashHandler(  744):     java.lang.reflect.Method.invokeNative(Native Method)
[task 2016-12-25T02:22:55.485577Z] 02:22:55     INFO -  12-24 18:20:34.332 E/GeckoCrashHandler(  744):     java.lang.reflect.Method.invoke(Method.java:525)
[task 2016-12-25T02:22:55.485912Z] 02:22:55     INFO -  12-24 18:20:34.332 E/GeckoCrashHandler(  744):     com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:737)
[task 2016-12-25T02:22:55.486261Z] 02:22:55     INFO -  12-24 18:20:34.342 E/GeckoCrashHandler(  744):     com.android.internal.os.ZygoteInit.main(ZygoteInit.java:553)
[task 2016-12-25T02:22:55.486547Z] 02:22:55     INFO -  12-24 18:20:34.342 E/GeckoCrashHandler(  744):     dalvik.system.NativeStart.main(Native Method)
[task 2016-12-25T02:22:55.486738Z] 02:22:55     INFO -  12-24 18:20:34.342 W/dalvikvm(  744): No implementation found for native Lorg/mozilla/gecko/GeckoAppShell;.reportJavaCrash:(Ljava/lang/Throwable;Ljava/lang/String;)V
[task 2016-12-25T02:22:55.487099Z] 02:22:55     INFO -  12-24 18:20:34.362 I/dalvikvm(  744): Failed resolving Lorg/mozilla/gecko/GeckoAccessibility$5; interface 2667 'Landroid/view/accessibility/AccessibilityManager$TouchExplorationStateChangeListener;'
[task 2016-12-25T02:22:55.487214Z] 02:22:55     INFO -  12-24 18:20:34.362 W/dalvikvm(  744): Link of class 'Lorg/mozilla/gecko/GeckoAccessibility$5;' failed
[task 2016-12-25T02:22:55.487470Z] 02:22:55     INFO -  12-24 18:20:34.362 E/dalvikvm(  744): Could not find class 'org.mozilla.gecko.GeckoAccessibility$5', referenced from method org.mozilla.gecko.GeckoAccessibility.setAccessibilityManagerListeners
[task 2016-12-25T02:22:55.487738Z] 02:22:55     INFO -  12-24 18:20:34.362 W/dalvikvm(  744): VFY: unable to resolve new-instance 5145 (Lorg/mozilla/gecko/GeckoAccessibility$5;) in Lorg/mozilla/gecko/GeckoAccessibility;
[task 2016-12-25T02:22:55.488186Z] 02:22:55     INFO -  12-24 18:20:34.372 I/dalvikvm(  744): Failed resolving Lorg/mozilla/gecko/GeckoAccessibility$5; interface 2667 'Landroid/view/accessibility/AccessibilityManager$TouchExplorationStateChangeListener;'
[task 2016-12-25T02:22:55.488257Z] 02:22:55     INFO -  12-24 18:20:34.382 E/AndroidRuntime(  744): FATAL EXCEPTION: FinalizerWatchdogDaemon
[task 2016-12-25T02:22:55.488458Z] 02:22:55     INFO -  12-24 18:20:34.382 E/AndroidRuntime(  744): java.util.concurrent.TimeoutException: java.io.FileOutputStream.finalize() timed out after 10 seconds
[task 2016-12-25T02:22:55.488777Z] 02:22:55     INFO -  12-24 18:20:34.382 E/AndroidRuntime(  744): 	at java.lang.Object.wait(Native Method)
[task 2016-12-25T02:22:55.488980Z] 02:22:55     INFO -  12-24 18:20:34.382 E/AndroidRuntime(  744): 	at java.lang.Object.wait(Object.java:401)
[task 2016-12-25T02:22:55.489285Z] 02:22:55     INFO -  12-24 18:20:34.382 E/AndroidRuntime(  744): 	at java.lang.ref.ReferenceQueue.remove(ReferenceQueue.java:102)
[task 2016-12-25T02:22:55.489572Z] 02:22:55     INFO -  12-24 18:20:34.382 E/AndroidRuntime(  744): 	at java.lang.ref.ReferenceQueue.remove(ReferenceQueue.java:73)
[task 2016-12-25T02:22:55.489885Z] 02:22:55     INFO -  12-24 18:20:34.382 E/AndroidRuntime(  744): 	at java.lang.Daemons$FinalizerDaemon.run(Daemons.java:170)
[task 2016-12-25T02:22:55.490092Z] 02:22:55     INFO -  12-24 18:20:34.382 E/AndroidRuntime(  744): 	at java.lang.Thread.run(Thread.java:841)
(Assignee)

Updated

a year ago
Assignee: nobody → gbrown
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
See Also: → bug 1321464
Duplicate of bug: 1313270
You need to log in before you can comment on or make changes to this bug.