Geolocation fails to show map with Error: 'notificationEl.checkbox is null'

RESOLVED DUPLICATE of bug 1323494

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 1323494
11 months ago
11 months ago

People

(Reporter: John Duncan, Unassigned)

Tracking

({regression, reproducible})

SeaMonkey 2.50 Branch
x86_64
All
regression, reproducible

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 months ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:53.0) Gecko/20100101 Firefox/53.0 SeaMonkey/2.50a1
Build ID: 20161224165148

Steps to reproduce:

I tried using the html5 geolocation feature when navigating to http://www.w3schools.com/html/html5_geolocation.asp


Actual results:

When the (as of right now, improperly styled) dropdown appeared to the left of the site favicon in the location bar (after I clicked the 'Try it' button on the page), and I clicked 'Share Location,' instead of it successfully sharing my location, nothing happens, and the Error Console shows:

Error: notificationEl.checkbox is null
Source File: resource://gre/modules/PopupNotifications.jsm
Line: 1339

The given line (1339) that is causing the error seems to be: 
checkboxChecked: notificationEl.checkbox.checked


Expected results:

The browser should have successfully shared by geolocation (my personal site utilizes this functionality for a weather script I wrote, so I know this worked in 2.40).

I am using SeaMonkey 2.50a1 from Tinderbox build 1482590088 compiled on Dec 25, 2016

Here is a screenshot of the weirdly-styled dropdown popup menu as well: http://i.imgur.com/ExLeSPI.png
(Reporter)

Updated

11 months ago
Keywords: regression
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86_64

Comment 1

11 months ago
Error console message is REPRODUCIBLE with Server-Installation of  unofficial (by FRG) en-US SeaMonkey 2.50a1 (NT 6.1; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0 Build 20161219235428  (Default Classic Theme) on German WIN7 64bit:
Timestamp: 26.12.2016 08:31:51
Error: notificationEl.checkbox is null
Source File: resource://gre/modules/PopupNotifications.jsm
Line: 1339

@reporter:
Why "weirdly-styled dropdown"? What did you expect?
Keywords: reproducible
OS: Mac OS X → All

Comment 2

11 months ago
2.40 brings up a warning trying geolocation on <http://www.w3schools.com/html/html5_geolocation.asp>:
Timestamp: 26.12.2016 09:16:25
Warning: Error in parsing value for 'top'.  Declaration dropped.
Source File: http://www.w3schools.com/html/html5_geolocation.asp
Line: 0
Source Code:
undefinedpx

But here the HTML5 Geolocation works, shows a map on the web page

a) Works fine with FF 53.0a1 (2016-12-15) (32-bit)
b) I did not find a preference which might be responsible for the problem
Summary: Error: 'notificationEl.checkbox is null' when using geolocation → Geolocation fails to show map with Error: 'notificationEl.checkbox is null'

Comment 3

11 months ago
c) Using newly created user profile does not heal the problem
d) I did not find an obvious DUP with <https://bugzilla.mozilla.org/buglist.cgi?cmdtype=dorem&remaction=run&namedcmd=dups1325844&sharer_id=41036>
Status: UNCONFIRMED → NEW
Ever confirmed: true
I am really sure this is a problem because of the changed notifications tracked in bug 1323494. Will go away once this is fixed. If not reopen then.
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1323494
(Reporter)

Comment 5

11 months ago
@Rainer Bielefeld:
The dropdown styling seems to be somewhat broken and non-OS specific in the current version of the default theme on my version of SM 2.50a1 on OSX64. The button is strangely placed and looks weird in comparison to how it looked in SM 2.46.

Here are some comparisons:
2.46 xpi install dropdown: http://i.imgur.com/zxm0oXU.jpg
2.46 webaudio controls: http://i.imgur.com/OPbzKYg.jpg
2.46 geolocation dropdown: http://i.imgur.com/lJIYmNO.jpg

2.50a1 xpi install dropdown: http://i.imgur.com/5tII9EA.jpg
2.50a1 webaudio controls: http://i.imgur.com/i9AbrrF.jpg
2.50a1 geolocation dropdown: http://i.imgur.com/SaclsIV.jpg

Also, the extensions icon does not show up in its row inside of the about:addons page in 2.50a1: http://i.imgur.com/GOKRlIx.jpg

@FRG:
Okay, that seems to make sense. That bug probably also covers the aesthetic issues that I have described above.
The webaudio controls were recently changed. I think either starting with 2.47 or 2.48 you will see them as they are now in 2.50. Can't say I care about the new volume control which now requires a click but I am not hip so ... :) If there are a problem with these controls under SeaMonkey please open another bug. Geolocation and xpi install should be covered by the notifications bugs.
(Reporter)

Comment 7

11 months ago
Okay. As you noted, the controls work fine, they've just changed aesthetically. Also probably worth it to mention that the Error Console css styling moved from global/ to communicator/ sometime in between 2.46 and 2.50. I know I had to backport both that change and the webaudio css change to my theme as well.

So, at this time, it seems the geolocation and xpi install stuff will be fixed, and thus, the css should not be modified? Only css changes I've made so far are for webaudio and the browser console in my theme.
The help viewer was also moved from toolkit to suite. Check the css there too.
You need to log in before you can comment on or make changes to this bug.