Invisible close/zoom buttons in background window still work

RESOLVED DUPLICATE of bug 120068

Status

()

Core
XUL
--
minor
RESOLVED DUPLICATE of bug 120068
16 years ago
16 years ago

People

(Reporter: Matthew Paul Thomas, Assigned: jag (Peter Annema))

Tracking

Trunk
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
To reproduce:
1.  Arrange two Navigator windows so that no matter which one is in front, the
    zoom boxes of both of them will be visible. (The zoom box is the button
    next to the collapse box in the top right corner.)
2.  Take note of where the zoom box is in the window which has focus.
3.  Give the other window focus.
4.  Click on the (now invisible) zoom box in the original window.
5.  Repeat steps 1--4 with the close box instead of the zoom box.

What happens:
4.  The window gets focus and zooms.
5.  The window gets focus and closes.

What should happen:
*   The window gets focus, and nothing else.
*   The window gets focus, and nothing else.

Problem occurs with:
*   close and zoom buttons in build 2002031808, Mac OS 9.2

Problem does not occur with:
*   collapse buttons in the same windows
*   Mac OS Finder
*   Microsoft Internet Explorer 5.1
*   BBEdit Lite
*   ...

Comment 1

16 years ago
ouch; I am often annoyed by this too; we should fix this!
Keywords: nsbeta1
(Assignee)

Comment 2

16 years ago
Dupe of bug 120068.

*** This bug has been marked as a duplicate of 120068 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.