AdSense background displays transparent when it should be white

UNCONFIRMED
Unassigned

Status

()

Core
Layout
P3
minor
UNCONFIRMED
11 months ago
4 months ago

People

(Reporter: simplafied, Unassigned)

Tracking

50 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(5 attachments, 2 obsolete attachments)

(Reporter)

Description

11 months ago
Created attachment 8821866 [details]
firefox-adsense-bug.png

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161208153507

Steps to reproduce:

Visit this site in Firefox http://blacklisted-loans-south-africa.co.za/ and view AdSense ad units displaying text ads. 

Visit this site in Edge http://blacklisted-loans-south-africa.co.za/ and view AdSense ad units displaying text ads. 


Actual results:

You will see that the background of the Ads which is set as white #FFFFFF in AdSense displays as transparent making the ads appear blue. They appear white in both Microsoft Edge and Chrome which is correct.


Expected results:

The ad unit background colour is set to white #FFFFFF and displays as such in Chrome and Edge, not sure why though have noticed recently that they are not. Cannot say exactly when this started, it is one of my websites and at first thought it was an AdSense issue.
(Reporter)

Updated

11 months ago
Severity: normal → minor

Comment 1

11 months ago
I don't see this ad on this website. Any link to see it every time?
Flags: needinfo?(simplafied)
(Reporter)

Comment 2

11 months ago
Hi, unfortunately it's not possible to see the exact same ad with Adsense every time. If you visit the site again and then navigate a few pages you should get the same thing happenin. Basically it's an AdSense text add appearing in a block designed for images. AdSense displays plain text ads and image ads in the blocks.

The image ads are displayed as images though the text ads are basically plain text. For some reason the background has started being visible this was not previously the case.

There are lots of ad blocks on the site so if you navigate a few pages you should see it. The only reason you won't is if only image ads display, then it will look fine. Navigate off the home page to a less important page then press F5, this will refresh the ads. Do it a few times and text ads should display



(In reply to Loic from comment #1)
> I don't see this ad on this website. Any link to see it every time?

Comment 3

11 months ago
When you see the ad, could you save the page as .html file, verify the ad is displayed (with the bug) when loading the file locally and attach it to the bug report?

Updated

11 months ago
Component: Untriaged → Layout
Product: Firefox → Core
(Reporter)

Comment 4

11 months ago
Hi again, I just went back to do as you requested and now I see that the problem is fixed. I have no idea why, though I have cleared my browser cache since then. 

Possibly that may have something to do with it, I am not sure. The ads appear to be fine now. I really have no idea why they are back to normal.

Updated

11 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago
Flags: needinfo?(simplafied)
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

11 months ago
If it happens again I will try and be more specific as to what I did to duplicate the event. Everything seems perfectly fine, possibly it was something to do with Google AdSense and nothing to do with Firefox though the problem did not appear in Edge or Chrome.

Sorry to bother you.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 6

11 months ago
Though if you see the attached image in the original post there definitely was an error evident.
(Reporter)

Comment 7

10 months ago
Created attachment 8826528 [details]
Firefox Adsense - Background color is visible

In Firefox on this page I get the background appearing http://quick-cash.co.za/links.html
(Reporter)

Comment 8

10 months ago
Created attachment 8826529 [details]
Edge bacgkround is invisible
(Reporter)

Comment 9

10 months ago
Sorry to open this again though I can once again see this happening with AdSense, just letting you know. Please see the new screenshots of this I have added to the Bug for ads on this page http://quick-cash.co.za/links.html

Comment 10

10 months ago
When you see the ad with the issue, can you save the page and load the save locally to know if the issue is reproducible. If that's the case, put the save in a zip file and attach it to the bug report.
(Reporter)

Comment 11

10 months ago
Created attachment 8826559 [details]
As requested the ZIP file of the local save of the HTML of the page

Comment 12

10 months ago
Which HTML page do I need to load? links.html?
(Reporter)

Comment 13

10 months ago
Created attachment 8826560 [details]
Apologies, that is the HTML file to load
(Reporter)

Comment 14

10 months ago
Sorry forgot to put the HTML file in, the ZIP is for the page resources. 1 min, I will put them all together in another ZIP
(Reporter)

Comment 15

10 months ago
Created attachment 8826561 [details]
That is the page and the resources all together in a single ZIP
(Reporter)

Comment 16

10 months ago
Sorry about that, check the last Attachment I uploaded, unzip that and then there should be an HTML file outside of the page resources folder 

Link Exchange Banner Exchange _ Quick-Cash.co.za _ Get Loans - No Fees - Easy Approval.htm

Updated

10 months ago
Attachment #8826559 - Attachment is obsolete: true

Updated

10 months ago
Attachment #8826560 - Attachment is obsolete: true

Comment 17

10 months ago
I tried with the last zip, I don't see the ad, see my screenshot: http://imgur.com/JBAZgn8
(Reporter)

Comment 18

10 months ago
See it is blank, I am not sure AdSense will display in a cached version of the page. I am not sure how you can see it.

Give me 2 minutes to create a page for you to visit
(Reporter)

Comment 19

10 months ago
Okay, try visiting this page http://quick-cash.co.za/adsense-bug-test.html

The page only has AdSense ads on it

Comment 20

10 months ago
I'm not sure I'll be able to get the same ads because I'm visiting the page from France and ads from Adsense are geolocalized.
(Reporter)

Comment 21

10 months ago
I just used this tool https://gtmetrix.com/ to visit the page above and looked at the screenshot. I can see that in the screenshot using Firefox 49.0.2 the ads appear with a white background. However there definitely is an issue on my PC, maybe just mine, I am using 50.1.0
(Reporter)

Comment 22

10 months ago
I realise that, though see if you refresh the page by pressing F5 do you get any TEXT ads in the slots?

Comment 23

10 months ago
(In reply to simplafied from comment #22)
> I realise that, though see if you refresh the page by pressing F5 do you get
> any TEXT ads in the slots?

Wih the previous link, I get text and images: http://imgur.com/71nB3ft
(Reporter)

Comment 24

10 months ago
I see what you mean, you are not getting plain text ads to display. This might be due to your location having many more ads displaying then in South Africa and you are much less likely to see a plain text ad.

Okay, let me see if I can force the ads to display as TEXT ONLY, 1 minute

Comment 25

10 months ago
I can try to add a proxy from ZA in the settings of Firefox.
(Reporter)

Comment 26

10 months ago
Hi, please check that page again and see what happens, press F5 to refresh as the page has been updated. The ads may be blank, though give it 5/10 minutes and they should only display text now

http://quick-cash.co.za/adsense-bug-test.html
(Reporter)

Comment 27

10 months ago
Okay, I am not sure how to do that, the ads need a little time to become as I just changed them to text only

Comment 28

10 months ago
Ok I'll test.
(Reporter)

Comment 29

10 months ago
The proxy idea might work better, the text ads might not display, takes a while sometimes.
(Reporter)

Comment 30

10 months ago
Also try browsing this site using the proxy http://blacklisted-loans-south-africa.co.za/ the same problem happens there
(Reporter)

Comment 31

10 months ago
Morning if you visit this page http://quick-cash.co.za/adsense-bug-test.html today you should see that TEXT only ads are visible as the ads are now active.

Comment 32

10 months ago
I can't reproduce it with FF50/53, the background of text ads is white: http://imgur.com/cHs85Ow
(Reporter)

Comment 33

10 months ago
Created attachment 8826830 [details]
Compare this to your capture
(Reporter)

Comment 34

10 months ago
Damn, well sorry to trouble you, though definitely is occurring with me, see the image of the same page I just took right now.

Okay, I will leave this now, I just wanted to let you know.

Comment 35

10 months ago
Are you able to reproduce the issue:
1) with HWA disabled:
https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems#w_turn-off-hardware-acceleration

2) with a fresh profile:
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
(Reporter)

Comment 36

10 months ago
I will take a look when I have a bit more time.
Thanks for the help

Updated

4 months ago
Priority: -- → P3
You need to log in before you can comment on or make changes to this bug.