cannot save file 'source file could not be read'

RESOLVED DUPLICATE of bug 1326435

Status

()

Firefox
File Handling
RESOLVED DUPLICATE of bug 1326435
10 months ago
10 months ago

People

(Reporter: Alexander, Unassigned)

Tracking

50 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 months ago
User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161213225121

Steps to reproduce:

Hello, I see similar issues reported but none of the solutions of the old issues helped. Also tried asking support question [1] but I think it's time to move it to bugzilla.

It is similar problem to
https://support.mozilla.org/bg/questions/1026743
https://support.mozilla.org/en-US/questions/1134063
https://bugzilla.mozilla.org/show_bug.cgi?id=180672
https://bugzilla.mozilla.org/show_bug.cgi?id=171441

Issue is with Firefox 50.1.0 on Fedora 24. Cannot download file from:
http://dox.bg/files/dw?a=1abb6d1a24
(captcha only required digits and one has to click on the filename to download).

I see:
> /tmp/mozilla_avalon0/Tzudza6B.bin.part could not be saved, because the source file could not be read.
> Try again later, or contact the server administrator.

None of the solutions I could find worked. Restarting, compreg, accept-encoding - nothing.

I read also these articles to no avail:
http://kb.mozillazine.org/Source_file_could_not_be_read
http://kb.mozillazine.org/Unable_to_save_or_download_files

Midori browser can download this and other similar files. With the pointers of the people that participated on [1] I also found out other facts:
* in web console I see "The character encoding of a framed document was not declared. The document may appear different if viewed without the document framing it".
* Midori downloads the file as `ì5-1_19122016(6).pdf` while it is listed on the site as `м5-1_19122016(10).pdf`. This makes me thing that could really be an encoding issue.
* At the time error window appears, I really can copy the `.part` file. And it appears to have correct content. So issue is obviously in the code that should rename file back to the original filename. I can't understand why error happens before I have a chance to select a filename. I have configured firefox to ask me before downloading stuff but I don't have a chance to select what action do I want.

It would really help if somebody can look at the file soon. I don't know how long the file will stay on the server and it might be impossible to reproduce after it is gone.

[1] https://support.mozilla.org/en-US/questions/1151858
(Reporter)

Comment 1

10 months ago
FYI running firefox with a clean profile also did not help.

Updated

10 months ago
Component: Untriaged → File Handling

Updated

10 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1326435
You need to log in before you can comment on or make changes to this bug.