Closed Bug 1326018 Opened 5 years ago Closed 5 years ago

Crash in java.lang.NullPointerException: Attempt to invoke interface method ''int android.database.Cursor.getColumnIndexOrThrow(java.lang.String)'' on a null object reference at org.mozilla.gecko.activitystream.Utils.highlightSource(Utils.java)

Categories

(Firefox for Android Graveyard :: General, defect, P1)

Unspecified
Android
defect

Tracking

(firefox51 unaffected, firefox52 unaffected, firefox53 fixed)

RESOLVED FIXED
Firefox 53
Tracking Status
firefox51 --- unaffected
firefox52 --- unaffected
firefox53 --- fixed

People

(Reporter: kanru, Assigned: Grisha)

References

Details

(Keywords: crash, Whiteboard: [MobileAS])

Crash Data

Attachments

(1 file)

@Grisha: This looks like a regression from bug 1319245?
Blocks: 1319245
Flags: needinfo?(gkruglov)
Priority: -- → P2
Whiteboard: [MobileAS]
Sure looks like it!
Assignee: nobody → gkruglov
Status: NEW → ASSIGNED
Flags: needinfo?(gkruglov)
highlightsCursor object reference disappears underneath us while we're working through handling a highlight item click. One likely cause might be a race between BrowserApp's hideHomePager (which calls unloads home screen to clear resources, setting our cursor to null) and StreamRecyclerAdapter's onItemClicked (which is building up telemetry data using the cursor).
Comment on attachment 8825200 [details]
Bug 1326018 - Process telemetry for highlight click before url open action

https://reviewboard.mozilla.org/r/103392/#review104106
Attachment #8825200 - Flags: review?(s.kaspari) → review+
Iteration: --- → 1.13
Priority: P2 → P1
Pushed by gkruglov@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/478ee1543c0d
Process telemetry for highlight click before url open action r=sebastian
https://hg.mozilla.org/mozilla-central/rev/478ee1543c0d
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.