When output video frame to surface, send dummy samples.

RESOLVED FIXED in Firefox 53

Status

()

P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: jhlin, Assigned: jhlin)

Tracking

unspecified
Firefox 53
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox53 fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

2 years ago
Since RemoteVideoDecoder [1] does not use the data in output buffers anyway, use dummy samples as outputs saves some shared memory allocation and IPC percel serialization efforts.

Also, logcat dumps in bug 1298300 attachment 8822140 [details] shows some devices (MTK chipset) returns null output buffers after format changes sometimes. Use dummy samples instead of shared memory also works around that.
(Assignee)

Updated

2 years ago
Blocks: 1298300
(Assignee)

Updated

2 years ago
Assignee: nobody → jolin
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
(Assignee)

Updated

2 years ago
Attachment #8822345 - Attachment is obsolete: true
Attachment #8822345 - Flags: review?(snorp)
Comment hidden (mozreview-request)
Comment on attachment 8822359 [details]
Bug 1326026 - use bufferless samples for outputs when rendering to surface.

https://reviewboard.mozilla.org/r/101308/#review103076
Attachment #8822359 - Flags: review?(snorp) → review+
Hi John,

May I know when this patch will be landed ? Will it also be merged in to Firefox53?
Since I suppose the feature (pref-on Bug 1311960) of moving Android audio/video decoder out of application process will be enabled and landed in Firefox 53?

Can you please help with this ?? Thank you very much !
Flags: needinfo?(jolin)
Comment hidden (mozreview-request)

Comment 7

2 years ago
Pushed by jolin@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4b3a24d9a501
use bufferless samples for outputs when rendering to surface. r=snorp
(Assignee)

Comment 8

2 years ago
(In reply to Rachelle Yang [:ryang][ryang@mozilla.com] from comment #5)
> Hi John,
> 
> May I know when this patch will be landed ? Will it also be merged in to
> Firefox53?
> Since I suppose the feature (pref-on Bug 1311960) of moving Android
> audio/video decoder out of application process will be enabled and landed in
> Firefox 53?
> 
> Can you please help with this ?? Thank you very much !

 Thanks for the reminder and sorry for not noticing the autoland failure. Just landed it in inbound manually.
Flags: needinfo?(jolin)
Thank you, John!

Comment 10

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/4b3a24d9a501
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox53: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53

Comment 11

2 years ago
I see this bug should fix the problem reported on Bug 1298300 & Bug 1331391, but I've ran again across the issue of videos not working on youtube or other video pages (mp4, webm or html5). 
Out of the devices that I've checked on (including other devices running on Android 4), the issue was isolated to the Asus Transformers Pad (Android 4.2.1): the browser doesn't crash, but the video keeps buffering without any video or audio output.
It is reproducible also on Nightly 54. Please let me know if you think I should file a new bug.
Per comment 11, ni john.
Flags: needinfo?(jolin)
Priority: -- → P1
(Assignee)

Comment 13

2 years ago
(In reply to Oana Horvath from comment #11)
> I see this bug should fix the problem reported on Bug 1298300 & Bug 1331391,
> but I've ran again across the issue of videos not working on youtube or
> other video pages (mp4, webm or html5). 
> Out of the devices that I've checked on (including other devices running on
> Android 4), the issue was isolated to the Asus Transformers Pad (Android
> 4.2.1): the browser doesn't crash, but the video keeps buffering without any
> video or audio output.
> It is reproducible also on Nightly 54. Please let me know if you think I
> should file a new bug.

 Oana, could you please help capture logcat output? A new bug should be filed if the remote process crash stack is different.
Flags: needinfo?(jolin)
(Assignee)

Updated

2 years ago
Flags: needinfo?(oana.horvath)

Comment 14

2 years ago
Created attachment 8832849 [details]
logcat output - bug 1326026.txt

I attached the logcat file captured today (2017-2-2) on the Asus Transformers Pad (Android 4) device.
(Assignee)

Comment 15

2 years ago
(In reply to Oana Horvath from comment #14)
> Created attachment 8832849 [details]
> logcat output - bug 1326026.txt
> 
> I attached the logcat file captured today (2017-2-2) on the Asus
> Transformers Pad (Android 4) device.

 Oana, thanks a lot for the log. It doesn't show similar error as this bug, so I guess a new bug is needed after all. Also, do you mind if I share a private build with you to collect more debug info?

Comment 16

2 years ago
(In reply to John Lin [:jolin][:jhlin] from comment #15)
> (In reply to Oana Horvath from comment #14)
> > Created attachment 8832849 [details]
> > logcat output - bug 1326026.txt
> > 
> > I attached the logcat file captured today (2017-2-2) on the Asus
> > Transformers Pad (Android 4) device.
> 
>  Oana, thanks a lot for the log. It doesn't show similar error as this bug,
> so I guess a new bug is needed after all. Also, do you mind if I share a
> private build with you to collect more debug info?

Sure, happy to help.
Flags: needinfo?(oana.horvath)

Updated

2 years ago
See Also: → bug 1346235
You need to log in before you can comment on or make changes to this bug.