Cyrus server: Accesing email with embedded images in IMAP sub-folder displays alert and saving attachments fails

VERIFIED FIXED

Status

MailNews Core
Networking: IMAP
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: Chris Blackstone, Assigned: Bienvenu)

Tracking

({imap-interop})

Trunk
imap-interop

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

3.79 KB, patch
Cavin Song
: review+
(not reading, please use seth@sspitzer.org instead)
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

17 years ago
With Build ID 2002032108 on Mac OS X, Mac OS 9, and Win2k, emails sent from
Novell Groupwise to Groupwise account, forwarded via Groupwise rule to an IMAP
Server "lose" their attachment when moved to an IMAP folder.

I can view emails correctly as long as they are in my INBOX.
As soon as I move the email to a folder on the IMAP server, I can't download PDF,
GIF, or JPG attachments. Each time I try to access an attachment I get an error
message that says 
"Would you like to subscribe to user/cblackst/INBOX/bugs" (the emails are in a
folder called bugs)

This error appears immediately when I try to view emails with GIF and JPG images
attached (I'm guessing there's some relation to Mozilla trying to display the
images inline).
The error appears if I try to save the PDF attachment of an email.
I only get this error after I have moved the emails to a folder on my IMAP
server and then try to access the attachments.

does this make any sense?
(Assignee)

Comment 1

17 years ago
Changing summary and adding keywords. I suspect this is due to our handling of
the cyrus hierarchy delimiter of ".".
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Keywords: interop, nsbeta1
Summary: Moving email to IMAP folder displays alert when accessing attachments in forwarded email messages → Cyrus server: Accesing email with embedded images in IMAP sub-folder displays alert and saving attachments fails
(Assignee)

Comment 2

17 years ago
Chris, did you set up that other users namespace yourself or did the server do
it? It might help if you attached a protocol log:

http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap
(Reporter)

Comment 3

17 years ago
The server did it.

I tried to get a protocol log, but there is no seamonkey directory on the Mac
and the instructions don't work in mac OS X, which is my main working OS. 
(Assignee)

Comment 4

17 years ago
ok, I have a fix for this. I need to iron out some issues with imap mod-utf8
folder names before I attach the fix.
(Assignee)

Comment 5

17 years ago
Created attachment 75789 [details] [diff] [review]
proposed fix

need to use FindOnlineSubfolder to find sub folder, because it uses the online
name, which is what's in the urls. Also fixed a utf7 issue.
(Assignee)

Comment 6

17 years ago
Cavin, can you review?
(Assignee)

Comment 7

17 years ago
we really need to fix this for moz 1.0 - otherwise, we'll get lots of complaints
from cyrus users

Comment 8

17 years ago
Comment on attachment 75789 [details] [diff] [review]
proposed fix

r=cavin.
Attachment #75789 - Flags: review+
Comment on attachment 75789 [details] [diff] [review]
proposed fix

sr=sspitzer
Attachment #75789 - Flags: superreview+

Comment 10

17 years ago
Comment on attachment 75789 [details] [diff] [review]
proposed fix

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #75789 - Flags: approval+
(Assignee)

Comment 11

17 years ago
fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

17 years ago
Works correctly in 

Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.9+) Gecko/20020326
Build ID:  2002032603
(Reporter)

Comment 13

17 years ago
Works correctly in

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9+) Gecko/20020326
Build ID: 2002032603
(Assignee)

Comment 14

17 years ago
Chris, could you mark it verified, then? Thx.

Updated

16 years ago
QA Contact: huang → meehansqa

Comment 15

16 years ago
Marking as VERIFIED - reporter states this is no longer an issue
Status: RESOLVED → VERIFIED

Comment 16

16 years ago
*** Bug 132229 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.