Closed Bug 1326235 Opened 5 years ago Closed 5 years ago

The awesomebar dances up and down with each character typed when the text entered looks like a URL

Categories

(Firefox :: Address Bar, defect, P2)

52 Branch
defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox51 --- unaffected
firefox52 --- unaffected
firefox53 --- affected

People

(Reporter: jaws, Unassigned)

References

Details

(Whiteboard: [fxsearch])

Attachments

(1 file)

[Tracking Requested - why for this release]: regression from change in awesomebar behavior shipping in 52

STR:
Click on the location bar
Type "abc"
Enable Search Suggestions
Continue typing, the location bar should now read "abc.def"
As each letter is added after the period, the awesomebar will shift up and down

Note that the awesomebar doesn't get the shakes when backspace is used.

Tested on Windows 10 Nightly 53.0a1 (2016-12-29) (64-bit) and confirmed that it is a regression from bug 1256074 via mozregression.
I cannot reproduce just by typing "abc.def". I don't see any jumping at all, I tried typing both slow and fast.
Is it mandatory to enable search suggestions at that time?
After discussing on IRC, we figured this is a DPI problem, due to bug 1325816.
The only reason it happens after bug 1256074, is that such bug added a second entry to the popup.
No longer blocks: 1256074
Depends on: 1325816
Note, I couldn't reproduce cause I use 225% DPI setting, Jared uses 200%.
Remove tracking cause this is caused by one-off buttons that are Nightly only so far.
Priority: -- → P2
Whiteboard: [fxsearch]
(In reply to Marco Bonardo [::mak] from comment #3)
> Note, I couldn't reproduce cause I use 225% DPI setting, Jared uses 200%.

Correction (my fault), I was using 150% DPI settings.
See attached GIF file demostrating the issue (though, I'm not 100% sure this is what Jared meant by "awesomebar dances").
Attached image Demonstration
(In reply to ItielMaN from comment #6)
> See attached GIF file demostrating the issue (though, I'm not 100% sure this
> is what Jared meant by "awesomebar dances").

Yes, this is what I meant.
This should have been fixed by the dependency, Jared, could you please check on latest nightly?
Flags: needinfo?(jaws)
(In reply to Marco Bonardo [::mak] from comment #9)
> This should have been fixed by the dependency, Jared, could you please check
> on latest nightly?

Yep, that seems to be fixed as well on latest Nightly.
Yes, I can confirm that this is fixed for me now. 

I went to Display Settings and changed to 150% and was able to reproduce this bug with the latest Nightly. After signing out and signing back in, I am no longer able to reproduce the bug. Most display scaling requires signing out and back in, so this requirement is not unusual.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(jaws)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.