Closed Bug 1326271 Opened 3 years ago Closed 3 years ago

No way to accept/reject invite from email in SeaMonkey 2.46 + Lightning 5.1b1 [ReferenceError: nsMsgFolderFlags is not defined]

Categories

(Calendar :: E-mail based Scheduling (iTIP/iMIP), defect)

Lightning 5.1
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: commander4bugs, Assigned: MakeMyDay)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image Invite.png
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0 SeaMonkey/2.46
Build ID: 20161213183751

Steps to reproduce:

I have SeaMonkey 2.46 with Lightning 5.1b. My email is configured
to use IMAP provided by Office365. To access the Calendar, I am using
Exchange EWS Provider 3.9.0-beta2. Office 365 is configured to send
invites in the iCalendar format for IMAP.


Actual results:

When an invite email arrives, Lightning puts a toolbar over it where
Accept/Reject buttons used to be. See the attached screenshot to
get the idea.


Expected results:

Before I upgraded to 2.46+5.1b (in SeaMonkey 2.40 + Lightning 4.5b1),
there was a way to accept/reject the invite from the email toolbar.
Can you reproduce this with a local calendar?

This seems to be an issue of the EWS addon, see #542 / #549 at https://github.com/Ericsson/exchangecalendar/issues
Component: Lightning Only → E-mail based Scheduling (iTIP/iMIP)
Whiteboard: [addon: EWS provider]
(In reply to [:MakeMyDay] from comment #1)
> Can you reproduce this with a local calendar?

I created a local calendar, created an event and invited
myself to it. The resulting email does not have accept/reject
buttons either. It looks basically the same way as as
the screenshot I attached earlier.

> This seems to be an issue of the EWS addon, see #542 / #549 at
> https://github.com/Ericsson/exchangecalendar/issues

These do not seem to be related to the bug here. First,
I was using exactly the same version of the EWS Provider
when I was using 2.40+4.5b - and I was able to accept/reject
invites directly from the email before upgrading to 2.46+5.1b.

Second, both issue 542 and issue 549 you mentioned above are talking
about nothing happening AFTER the user accepts an invite.
This implies that people can actually click the "accept" button.
I my case, I do not even see this button and can not even tell
if I am getting to the problem described in issues 542 and 549.
> I created a local calendar, created an event and invited
> myself to it. The resulting email does not have accept/reject
> buttons either. It looks basically the same way as as
> the screenshot I attached earlier.

Have you tested this with EWS provider disabled? It is likely EWS provider hasn't picked up the latest changes to the imip bar.
Can you also check the error console for error messages?
(In reply to [:MakeMyDay] from comment #4)
> Can you also check the error console for error messages?

I cleared the error console and clicked on an email with an invite.
There are some relevant error messages:

Timestamp: 29-Dec-16 14:08:13
Error: ReferenceError: nsMsgFolderFlags is not defined
Source File: chrome://lightning/content/imip-bar.js
Line: 214

Timestamp: 29-Dec-16 14:08:13
Error: NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "nsMsgFolderFlags is not defined" {file: "chrome://lightning/content/imip-bar.js" line: 214}]'[JavaScript Error: "nsMsgFolderFlags is not defined" {file: "chrome://lightning/content/imip-bar.js" line: 214}]' when calling method: [calIOperationListener::onOperationComplete]
Source File: file:///C:/apershin/Profiles/apershin/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js
Line: 509

Timestamp: 29-Dec-16 14:08:13
Error: [Exception... "[JavaScript Error: "nsMsgFolderFlags is not defined" {file: "chrome://lightning/content/imip-bar.js" line: 214}]'[JavaScript Error: "nsMsgFolderFlags is not defined" {file: "chrome://lightning/content/imip-bar.js" line: 214}]' when calling method: [calIOperationListener::onOperationComplete]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: file:///C:/apershin/Profiles/apershin/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js :: calCompositeGetListenerHelper.prototype.onOperationComplete :: line 509"  data: yes]
Source File: resource://calendar/modules/calProviderUtils.jsm
Line: 641
(In reply to [:MakeMyDay] from comment #3)
> Have you tested this with EWS provider disabled? It is likely EWS provider
> hasn't picked up the latest changes to the imip bar.

I tried repeating the steps for the local calendar with the EWS Provider
disabled. The same result - no accept/reject buttons are shown for
invite messages.
Do you store sent messages in the same folder as incoming messages or in a separate folder?

Can you please check whether replacing nsMsgFolderFlags.SentMail by Components.interfaces.nsMsgFolderFlags.SentMail in line 214 of file imip-bar.js resolves or at least improves the the issue for you?
Blocks: 1218216
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(commander4bugs)
Keywords: regression
Whiteboard: [addon: EWS provider]
Sorry for the delay, New Year happened :)

(In reply to [:MakeMyDay] from comment #7)
> Do you store sent messages in the same folder as incoming messages
> or in a separate folder?

My email client is configured to store all sent messages
in the "Sent Items" folder on the IMAP server. I do this
by choosing "other folder" and then explicitly picking
"Sent Items" on the IMAP. In addition to this, I enabled
the "place replies to the same folder" checkbox.

> Can you please check whether replacing nsMsgFolderFlags.SentMail by
> Components.interfaces.nsMsgFolderFlags.SentMail in line 214 of file
> imip-bar.js resolves or at least improves the the issue for you?

Yes, adding "Components.interfaces." to imip-bar.js solved the problem.
Flags: needinfo?(commander4bugs)
Assignee: nobody → makemyday
Status: NEW → ASSIGNED
Duplicate of this bug: 1328575
Attached patch AddCi-V1.diffSplinter Review
This patch should take care. This needs to go up to ESR.
Attachment #8824534 - Flags: review?(philipp)
Attachment #8824534 - Flags: approval-calendar-esr?(philipp)
Attachment #8824534 - Flags: approval-calendar-beta?(philipp)
Attachment #8824534 - Flags: approval-calendar-aurora?(philipp)
Seamonkey users: please note this patch cannot not be backported to earlier versions of Lightning then  Lightning 5.3 (except ESR 4.7.x).

If you cannot update to a newer corresponding version of Seamonkey and need/want to stick with a joined folder for sent and received messages, please consider to patch your Lightning yourself as described in comment 7.
Attachment #8824534 - Flags: review?(philipp)
Attachment #8824534 - Flags: review+
Attachment #8824534 - Flags: approval-calendar-esr?(philipp)
Attachment #8824534 - Flags: approval-calendar-esr+
Attachment #8824534 - Flags: approval-calendar-beta?(philipp)
Attachment #8824534 - Flags: approval-calendar-beta+
Attachment #8824534 - Flags: approval-calendar-aurora?(philipp)
Attachment #8824534 - Flags: approval-calendar-aurora+
Duplicate of this bug: 1329400
Summary: No way to accept/reject invite from email in SeaMonkey 2.46 + Lightning 5.1b1 → No way to accept/reject invite from email in SeaMonkey 2.46 + Lightning 5.1b1 [ReferenceError: nsMsgFolderFlags is not defined]
https://hg.mozilla.org/comm-central/rev/8a495be3cf4e5e89f9863ff45b89c8dd2baee263
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [checkin-needed: comm-aurora][checkin-needed: comm-beta]
Target Milestone: --- → 5.5
Whiteboard: [checkin-needed: comm-aurora][checkin-needed: comm-beta] → [checkin-needed: comm-aurora][checkin-needed: comm-beta][checkin-needed: comm-esr45]
C-A (TB 52, Calendar 5.4):
https://hg.mozilla.org/releases/comm-aurora/rev/aac21d90435c545e0521ea3053addc2c0b008b50

C-B (TB 51, Calendar 5.3):
https://hg.mozilla.org/releases/comm-beta/rev/b67f6453153bea1f93712085a439207580925f2a
Whiteboard: [checkin-needed: comm-aurora][checkin-needed: comm-beta][checkin-needed: comm-esr45] → [checkin-needed: comm-esr45]
Target Milestone: 5.5 → 5.3
ESR 45, Calendar 4.7.6:
https://hg.mozilla.org/releases/comm-esr45/rev/8a588395e6b8a200e5bc5385beb687a61b8ba9e7
Keywords: checkin-needed
Whiteboard: [checkin-needed: comm-esr45]
Target Milestone: 5.3 → 4.7.6
This bug exists for me in Thunderbird 45.6.0 with Lightning 4.7.6. This is using Google calendar, with the "Provider for Google Calendar version 3.1" add-on. It has been this way for several months. I just use the Lightning part to display, and do the rest in a browser. :-(

Still broken as of today.
Right, well, the current version is 4.7.6 and it's not included in that version. It will be fixed in 4.7.7.

MakeMyDay, I messed up the target milestone yet again, can you please correct it.
Flags: needinfo?(makemyday)
(In reply to Jorg K (GMT+1) from comment #17)
> Right, well, the current version is 4.7.6 and it's not included in that
> version. It will be fixed in 4.7.7.

Is that coming any time soon? 4.7.6 is the current "shipping" version, and is unusable. Even a Thunderbird update to just pick up this one fix would be worth it.
This is fixed for the upcoming esr stability release, which is 4.7.7 - this still needs to be configured in BMO.

Philipp, can you please add the target milestones / version numbers?
Flags: needinfo?(makemyday)
This will be released approximately in about 2-3 weeks from now. You can patch the current version yourself as described in comment 7 or configure your outgoing mails not to be stored in the same folder as the incoming.
Target Milestone: 4.7.6 → 4.7.7
Duplicate of this bug: 1330568
Duplicate of this bug: 1333149
You need to log in before you can comment on or make changes to this bug.