Closed Bug 1326378 Opened 3 years ago Closed 3 years ago

Failures on OSX in 2.0.0/conformance2/programs/gl-get-frag-data-location.html

Categories

(Core :: Canvas: WebGL, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla53
Tracking Status
firefox51 --- fixed
firefox52 --- fixed
firefox53 --- fixed

People

(Reporter: jgilbert, Assigned: jgilbert)

References

Details

(Whiteboard: gfx-noted)

Attachments

(1 file)

OSX (at least NV) doesn't return locs for indexed names, just the base names.
Comment on attachment 8822617 [details]
Bug 1326378 - Infer indexed frag output location from base location on OSX. -

https://reviewboard.mozilla.org/r/101488/#review102158
Attachment #8822617 - Flags: review?(ethlin) → review+
Since this is a major way MRTs work in WebGL 2, this should be blocking.
Pushed by jgilbert@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/56ffc04f1794
Infer indexed frag output location from base location on OSX. - r=ethlin
Comment on attachment 8822617 [details]
Bug 1326378 - Infer indexed frag output location from base location on OSX. -

Approval Request Comment
[Feature/Bug causing the regression]: webgl2
[User impact if declined]:
[Is this code covered by automated tests?]:
[Has the fix been verified in Nightly?]:
[Needs manual test from QE? If yes, steps to reproduce]: 
[List of other uplifts needed for the feature/fix]:
[Is the change risky?]:
[Why is the change risky/not risky?]:
[String changes made/needed]:
Attachment #8822617 - Flags: approval-mozilla-aurora?
Comment on attachment 8822617 [details]
Bug 1326378 - Infer indexed frag output location from base location on OSX. -

Approval Request Comment
[Feature/Bug causing the regression]: webgl2
[User impact if declined]: Some WebGL 2 apps using MRTs may break, though a workaround in the app is simple.
[Is this code covered by automated tests?]:
[Has the fix been verified in Nightly?]:
[Needs manual test from QE? If yes, steps to reproduce]: 
[List of other uplifts needed for the feature/fix]:
[Is the change risky?]: Not risky.
[Why is the change risky/not risky?]: Not risky because it's simple, and IIRC what we used to do in the past. There is a test for this that we pass on OSX with this patch, but not without it.
[String changes made/needed]:
Attachment #8822617 - Flags: approval-mozilla-beta?
https://hg.mozilla.org/mozilla-central/rev/56ffc04f1794
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Comment on attachment 8822617 [details]
Bug 1326378 - Infer indexed frag output location from base location on OSX. -

WebGL2 related, Aurora52+, Beta51+
Attachment #8822617 - Flags: approval-mozilla-beta?
Attachment #8822617 - Flags: approval-mozilla-beta+
Attachment #8822617 - Flags: approval-mozilla-aurora?
Attachment #8822617 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.