Log-in window no longer appearing

RESOLVED INVALID

Status

External Software Affecting Firefox
Other
RESOLVED INVALID
2 years ago
a year ago

People

(Reporter: Colin Howard, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161208153507

Steps to reproduce:

Tried to log-in to a site I last used a week ago and do have an account on. It was successfully accessed from MS EDGE after Firefox failed.
this is the site https://www.jackpot.com/
Log-in and create account are in the small strip top right of the window.
I even ret cookies and popups for this site to completely free of user intervention.


Actual results:

Nothing


Expected results:

A small pop-up window should appear to enable entry of the account details. Nothing happened
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64

Comment 1

2 years ago
WFM with FF50 on in 7, when I click on "sign in" or "sign up", I see a form as pop-up to enter ID/pwd.

Does it work in safe mode?
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

With a fresh profile?
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(that.man.colin)
(Reporter)

Comment 2

2 years ago
Same effect in Safe Mode and with a new "Default User" profile.

I can now confirm the date of the last successful access of that site as December 28th, 2016 @ 17:28 CET (Stockholm). Firefox last updated December 1st, 2016 @ 09:39:06 - 50.0.2 (20161129173726)

For what it's worth I have activated the Web Console CTRL+SHIFT+K whilst trying to invoke the log-in function and there doesn't appear to be any code displayed when clicking on the link button and the bottom of the window just indicates ----   javascript;    ----- with no indicated link for either [Sign in] or [Sign up]. The language preference button is a simple drop-down menu.
(Reporter)

Comment 3

2 years ago
Not certain whether or not it is significant.
The windows screen split icon permitting side by side split screen ability (a little monitor icon split vertically by default) always used to be attached to the active FF window - almost "glued" to the minimise window button.
It has disappeared completely.
There have been no Windows updates since December 15th, 2016.
My apologies if this is a "red herring" but I'm assuming more information is good.

Comment 4

2 years ago
Do you have add-ons in your new profile created to test the issue? If yes, provide the list.
(Reporter)

Comment 5

2 years ago
Created attachment 8823132 [details]
screen dump of installed plugins in "clean" user test profile
(Reporter)

Comment 6

2 years ago
The test profile was simply the automatic default for a new profile "default user".
One Extension which is pre-configured for all browsers - Kaspersky Protection - was automatically included but not enabled by the creation of the default profile.
I have attached a screen dump [ffplugins] of the plugins that were automatically configured by the new profile creation which also identifies their settings.
I don't recall seeing anything identifying itself as automatically updated in the couple of days between the successful site access and its failure.
You will observe ROBLOX in the list which is used by one of my children on her own user account. I have sometimes noted intermittent problems in computer operations after this environment has been utilised and simply restarted the PC which always resolved the issues. I can confirm that ROBLOX had been used earlier in the day upon which the reported "malfunction" occurred but it had not proven necessary to perform a re-start on this occasion.

Comment 7

2 years ago
Are you using a Kaspersky module to manage your passwords?
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170118123726

I still cannot reproduce the issue using FF latest release 51.0 and FF latest Nightly 54.0a1.

Can you please retest this using latest FF release and latest Nightly build (https://nightly.mozilla.org/) and report back the results ? When doing this, please use a new clean Firefox profile, maybe even safe mode, to eliminate custom settings as a possible cause (https://goo.gl/PNe90E).

Also can you please provide an answer regarding the question from comment 7?
 
Thanks.
(Reporter)

Comment 9

2 years ago
My apologies, I misinterpreted message 7 status in my mail client, assuming it was item 4 which I had already responded to twice I inadvertently marked it as read. I promise to look more closely next time :)  ---   No, I don't use ANY password management modules.

I am already on latest FF 51 and also created a new profile for the last test. Additionally, the list of extensions and addons automatically created in the new profile was provided. None of my own personalised extras was active. Could it be a problem with regions? My location is Sweden and it's a local purchase with Swedish layout keyboard. There are six user accounts with default languages split equally - three each Swedish and English.

In all honesty, I don't really feel confident in messing around with "nightly" experimental builds as this is the family PC and I can't risk denying others access to their University material.

The error reported is not overly significant as I simply use a different browser as appropriate but any consequent loss of access for other family members would be catastrophic.
Hi Colin,

I tested this issue with a VPN - locatization Sweden and could not reproduce it. 
Can you please provide the Extensions list from about:addons from your profile? The list that you provided is with plug-ins.

Thank you.
(Reporter)

Comment 11

2 years ago
Hi there, Roxana,
Uploading a screen dump of the installed extensions imminently.
I am about to uninstall Awesome Screen Shot Capture as it now seems to require me to create a cloud storage account with them so others may comment on my captures. No WAY!
It might take me a few moments to re-discover how to upload the image :).
(Reporter)

Comment 12

2 years ago
Created attachment 8834309 [details]
FFExtensions.png

Hi Roxana,
Found the upload facility :).
Hi Colin,

Seems you have Kaspersky Protection add-on which is automatically installed by your system.
Can you please disable Kaspersky Protection add-on and retest the issue?

Thank you.
(Reporter)

Comment 14

2 years ago
Hi again, Roxana,
This may sound confusing. I had originally tested with a "clean" environment both with and without Kaspersky and the results were identical - NO sign in window.

I should advise that Kaspersky will automatically activate itself as soon as FF is invoked so I was constantly attempting to ensure that I was actually testing with Kaspersky "OFF".

The characteristics have subsequently changed in that I now get a sign in window but the response is an interminable "polling?" with three animated colour spots and the spinning disk symbol. This state is identical with Kaspersky both "ON" and "OFF".

I wanted to be able to thoroughly define what was happening and as I was testing I inadvertently opened a second tab to the site (I have it bookmarked) and it automatically logged into my account.

Confusing, especially as I wasn't at that stage certain how my procedures had changed between the failures and a success.

A more thorough test has identified that with Kaspersky "ON", I can open any number of tabs to the target and the result is the same - just the sign in popup and the animation.

If I start a new FF session and turn Kaspersky "OFF" the result is the same - just the sign in popup and the animation - even for multiple tabs.

However, If I start a FF session, open the target site from a bookmark and then turn Kaspersky "OFF", the next access with a bookmark immediately passes straight through to my account, without the need for the "sign-in" popup - as one would expect with stored passwords but no secondary verification at the site level. Interestingly, if I then turn Kaspersky back "ON" again, another opened tab to the site from a bookmark still works perfectly.

I should also mention that cookies self destruct for most sites upon closing their tabs and if I close ALL the target's open tabs I then get the same situation where it will only sign in after a couple of failures and then turning Kaspersky "OFF". SEE addons: cookie monster and self-destructing cookies.

I suspect the host's cookie treatment and my cookie destruction after the closing of that host's tabs has some significant impact upon the system.

I do hope my explanation of these observations is not too confusing. I think I had previously tried white listing the site through my cookie managers but in all honesty, I can't be 100% certain. I can probably undertake some longer term testing with all permutations of the site's cookies white listed/Self-Destructing, Kaspersky ON/OFF and single/multiple opened tabs if that would help. I could also flag it to Kaspersky and the target site if you feel that is appropriate but beyond your own remit.

My apologies if this seems more like a personal message than a testing report.

Best regards,
Colin
Component: Untriaged → Other
Product: Firefox → External Software Affecting Firefox
Version: 50 Branch → unspecified

Comment 15

a year ago
I'm going to close this out in our bug tracker because it seems clear that this is an issue with the Kaspersky software and you should file the bug report with them. Although I will recommending uninstalling all antivirus software except for the Windows defender default: it has been shown to reduce your overall security.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(that.man.colin)
Resolution: --- → INVALID
(Reporter)

Comment 16

a year ago
Hi Benjamin - would you consider it more likely that the culprit is Kaspersky rather than one of the cookie managers as it seems to me that the effect is related to something in the treatment of the cookies and multiple windows. Also, I haven't experienced it with any other pop-up or sign in so could it conceivably be the site itself. Don't misinterpret - I'm not questioning your judgement as you have a wealth of experience in these matters and I'm just floundering in the dark whilst trying to clearly identify whether I should escalate it with one or all four of the potential counterparts.
Not sure whether you are advising that Kaspersky has been shown to reduce my overall security or that removing Kaspersky and relying solely upon defender has been shown to reduce my overall security. Could you possibly elucidate.
Many thanks in anticipation,
Colin
You need to log in before you can comment on or make changes to this bug.