Disabled sound indicator blinks in tab when audio stops

VERIFIED FIXED in Firefox 52

Status

()

defect
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: arni2033, Assigned: jaws)

Tracking

({regression})

Trunk
Firefox 53
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox51 unaffected, firefox52 verified, firefox53 verified)

Details

Attachments

(1 attachment)

Reporter

Description

3 years ago
>>>   My Info:   Win7_64, Nightly 53, 32bit, ID 20161119030204 (2016-11-19)
STR_1:
1. Open https://www.iandevlin.com/html5test/webvtt/html5-video-webvtt-sample.html
2. Mute the tab (Ctrl+M)
3. Doubleclick play button in video controls
4. Wait 3 seconds

AR:  Sound indicator blinks in tab when audio stops (briefly disappears, then appears again)
ER:  Sound indicator shouldn't blink

This is regression from bug 1311799. Regression range:
> https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=b99f3a05db461e9a4384d95a95c7ecbfde863bc4&tochange=36105103e8699a45893b16745e8b8f85daebf82a
Reporter

Updated

3 years ago
No longer blocks: 1277113
Reporter

Comment 1

3 years ago
@ Jared Wein [:jaws] (please needinfo? me):
It seems that this is a regresion caused by your change. Please have a look.
Severity: enhancement → normal
Status: UNCONFIRMED → NEW
Component: Untriaged → Tabbed Browser
No longer depends on: 1234016
Ever confirmed: true
Flags: needinfo?(jaws)
See Also: 1234016
Summary: Disabled sound indicator blinks in tab when audio stops@ Jared Wein [:jaws] (please needinfo? me): It seems that this is a regresion caused by your change. Please have a look. → Disabled sound indicator blinks in tab when audio stops
Whiteboard: testing
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Attachment #8823433 - Flags: review?(gijskruitbosch+bugs) → review?(dtownsend)

Comment 3

3 years ago
mozreview-review
Comment on attachment 8823433 [details]
Bug 1326593 - Keep the soundplaying icon visible after audio has stopped playing if the tab has been muted.

https://reviewboard.mozilla.org/r/101946/#review102346
Attachment #8823433 - Flags: review?(dtownsend) → review+

Comment 4

3 years ago
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1aa5bd4c4769
Keep the soundplaying icon visible after audio has stopped playing if the tab has been muted. r=mossop

Comment 5

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/1aa5bd4c4769
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
Please request Aurora approval on this when you get a chance.
Flags: needinfo?(jaws)
Comment on attachment 8823433 [details]
Bug 1326593 - Keep the soundplaying icon visible after audio has stopped playing if the tab has been muted.

Approval Request Comment
[Feature/Bug causing the regression]: regression from bug 1311799
[User impact if declined]: sound icon may fade out unnecessarily
[Is this code covered by automated tests?]: no, manual testing
[Has the fix been verified in Nightly?]: yes, by myself
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no, simple css change
[Why is the change risky/not risky?]: simple css change
[String changes made/needed]: none
Flags: needinfo?(jaws)
Attachment #8823433 - Flags: approval-mozilla-aurora?
Comment on attachment 8823433 [details]
Bug 1326593 - Keep the soundplaying icon visible after audio has stopped playing if the tab has been muted.

fix ui regression in aurora52
Attachment #8823433 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Comment 10

3 years ago
I have reproduced this bug on Nightly 53.0a1 (2016-12-31) (32-bit) , Windows 8.1 (64-bit).

This bug's fix is verified on Latest Nightly 53.0a1 and Aurora 52.0a2.

Latest Nightly
Build ID : 20170111030235
User Agent : Mozilla/5.0 (Windows NT 6.3; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0

Aurora
Build ID : 20170112004017
User Agent :Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0

[bugday-20170111]

Updated

3 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.