QuickLaunch first browswer window address bar doesn't accept input

VERIFIED DUPLICATE of bug 130915

Status

Core Graveyard
QuickLaunch (AKA turbo mode)
VERIFIED DUPLICATE of bug 130915
17 years ago
6 years ago

People

(Reporter: Juan Lang, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

Warning:  intermittent on my machine (2 out of the last 3 reboots).  The first
browser window opened with QuickLaunch enabled doesn't allow entry in the
address bar.  The address bar appears blank, and most keystrokes don't appear to
have any effect.  Pressing Enter is the exception--it appears to reload the
current page.  Selecting a new address using the address dropdown doesn't
actually change the page, instead the current page is reloaded.

Pasting a new address into the address bar from the clipboard appears to change
the behavior.  After doing so, I can type an address in.  However, the page I
type in is not loaded.  The current page is reloaded instead.  Selecting an
address using the address dropdown will now load the selected page, although the
address bar doesn't change to reflect the new page.  (It remains at the
previously typed text.  So, for example, if my home page is slashdot.org, I type
nytimes.com, it has no effect.  Selecting maps.yahoo.com from the address bar
goes to that page, but the address bar displays nytimes.com.)

Reproducible: Sometimes
Steps to Reproduce:
1. Enable QuickLaunch
2. Reboot (or log off/log back on)
3. Open a browser window using the Mozilla icon in the startup icons list (not
sure if this is necessary)
4. Try typing an address in the address bar.

Actual Results:  No keystrokes were accepted in the address bar, with the
possible exception of the Enter key.

Expected Results:  "Normal" behavior--display typed keystrokes, pop down address
bar with matching addresses, open the selected/typed address when Enter is pressed.

Comment 1

17 years ago
I suspect this is bug 103197 biting us again.

Reassigning to jag since he has worked on focusing the urlbar in Navigator (or
so I believe, maybe it's bryner's?).  I'll bet another strategically placed
setTimeout will fix it...
Assignee: law → jaggernaut
(Assignee)

Comment 2

17 years ago
Can you click in the address bar to make it work?

When you press tab, where does it take you?
(Reporter)

Comment 3

17 years ago
Nope, it's not a focus problem.  Pressing tab brings focus to the strange 
little focus window in the left of the browser window (apparently one pixel 
wide, or maybe zero wide, and same height as the browser window; another tab 
highlights the first link on the page).

This isn't true for subsequent windows I open.

Comment 4

17 years ago
I've got a patch brewing for this

Comment 5

16 years ago
Is it possible that you're loading the browser window before QuickLaunch
finishes it's initial load (bug 130915)?
(Reporter)

Comment 6

16 years ago
I suppose anything's possible, though my startup sequence is rather long.  My
startup sequence:
- log in to Windows; all the auto-started apps start
- wait for a network login dialog (product I develop for my employer, similar to
802.1x)
- log in, wait for confirmation of success
- go to cmd.exe, check ipconfig to see if I've gotten an IP address yet (no IP
until after network login)
- now start Moz.

How can I tell if QuickLaunch has finished?
(Reporter)

Comment 7

16 years ago
Just tested by waiting a REALLY long time.  You're right, it fixes itself after
a long wait, so duplicates bug 130915.

*** This bug has been marked as a duplicate of 130915 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 8

16 years ago
verified
Status: RESOLVED → VERIFIED
Component: QuickLaunch (AKA turbo mode) → QuickLaunch (AKA turbo mode)
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.