refresh occurs on 'view page source'

VERIFIED DUPLICATE of bug 55583

Status

()

Core
Networking
VERIFIED DUPLICATE of bug 55583
16 years ago
16 years ago

People

(Reporter: Terry Davis, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031115

This has to do with the caching somehow but mozilla will go fetch the page again
if it cannot find it in the cache.  This is bad in my opinion.  This will
re-exec CGI's if they are on the page.

Reproducible: Sometimes
Steps to Reproduce:
1. Open a page
2. Click View/Page Source
3. Notice a fetch in webserver logs

Actual Results:  Sometimes a re-fetch will happen in the server logs.
Sometimes mozilla will not go get the page from the server.

Expected Results:  I expect it to always look at what it has already fetched.
This may be excluded if the cache is set to zero.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 55583 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.