Closed Bug 1326684 Opened 7 years ago Closed 4 years ago

Pressing PageUp/PageDown moves caret outside of contenteditable element. The element itself looses focus

Categories

(Core :: DOM: Editor, defect, P3)

defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox75 --- unaffected
firefox76 --- unaffected

People

(Reporter: arni2033, Unassigned)

Details

>>>   My Info:   Win7_64, Nightly 49, 32bit, ID 20160526082509
STR_1:
1. Open url [1]
2. Click on word "broken"
3. Press PageUp or PageDown
4. Type "z"
5. Press Up

AR:
 Step 3 - caret disappears from [contenteditable].
 Step 4 - caret appears before word "Firefox"
 Step 5 - caret disappears completely. [contenteditable] looses focus
ER:  (just like in textarea)
 Step 3 - no visible action
 Step 4 - "z" is typed where caret was in Step 2
 Step 5 - caret moves to the beginning of the line

Note:  There's no info whether this bug is a regression since version 28 or not. I never said it is.

> [1] data:text/html,<span style="position:fixed;bottom:0px;">Firefox<br>Regressions<br>Since<br>Version<br>28<br><span></span><div contenteditable>"This was working fine as it was. Now it's broken."<br></div><span></span></span>
> [2] data:text/html,<body style="height:10000px" onload="function F(el){document[el].scrollTop='10000'};F('body');F('documentElement');"><span style="position:fixed;bottom:0px;">Firefox<br>Regressions<br>Since<br>Version<br>28<br><span></span><div contenteditable>"This was working fine as it was. Now it's broken."<br></div><span></span></span>
Component: Untriaged → Editor
Product: Firefox → Core
No longer blocks: 1277113
step 3 might seem to be selection component.  But I confirm this on 53.0a1
Priority: -- → P3

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:75.0) Gecko/20100101 Firefox/75.0
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:76.0) Gecko/20100101 Firefox/76.0

Could not reproduce

Step 3 - Page Up and Page Down does not affect caret (unlike Chrome)
Step 4 - z appeared where it should be
Step 5 - Up and Down moves caret to the beginning and end of the line

Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.