Closed Bug 1326738 Opened 3 years ago Closed 3 years ago

Images, intentionally disabled via permissions.default.image=2, now are less discoverable than broken images

Categories

(Core :: General, defect)

49 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox-esr52 --- wontfix
firefox53 --- wontfix
firefox54 --- wontfix
firefox55 --- fixed

People

(Reporter: arni2033, Assigned: emk)

References

Details

(Keywords: regression, Whiteboard: [ele:1b])

Attachments

(1 file)

>>>   My Info:   Win7_64, Nightly 52, 32bit, ID 20161001030430 (2016-10-01)
STR_1:
1. Disable images in Firefox (open about:config and set pref "permissions.default.image" to 2)
2. Open attachment 8708624 [details]

AR:  The 16th testcase doesn't display broken image
ER:  Either X or Y
 X) Disabled images should be threated like broken images, and be just as discoverable
 Y) Disabled images should be MORE discoverable, because intentionally disabled images won't change
    size on their own, and therefore there're no restrictions like bug 1205027

This is regression from bug 1205027. Regression range:
> https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=192969a0735a5973a3f5234b6ccd3c2bc4a5a48f&tochange=4353662915021fe5da16a9df0bf4ab4efee426c5
No longer blocks: 1277113
Component: Untriaged → General
Product: Firefox → Chat Core
Version: Trunk → trunk
Product: Chat Core → Core
Version: trunk → Trunk
Hello, I'm asking your help with an experiment with making decisions on bugs. You've been needinfo'ed on this bug. I'd like you to take one action to help this bug make progress toward a decision. The things you can do include:

* If you know or have a good guess of which product and component this bug belongs to, change the product and component of the bug
* If you know of the right person to ask about this bug, redirect the needinfo to them
* If you cannot reproduce the bug, close it

All we need you to do is one thing that will help us make a decision on the bug or resolve it.

Thank you for your help with this. If you have questions, please contact emma@mozilla.com.
Flags: needinfo?(choller)
Whiteboard: [ele:1b]
Forwarding the needinfo to :emk per regression range in comment 0. Can you please check if this regression range is correct and decide how to proceed? Thanks.
Flags: needinfo?(choller) → needinfo?(VYV03354)
I'm sure the regression range is correct. We should use nsIImageLoadingContent.loadingEnabled and nsIImageLoadingContent.imageBlockingStatus to catch user-disabled images.
Flags: needinfo?(VYV03354)
I got bugmail saying you were asking for review, but there are no patches on this bug, so I suspect a bugzilla bug may have trashed your attachments? Try again?
Flags: needinfo?(VYV03354)
(In reply to Timothy Nikkel (:tnikkel) from comment #4)
> I got bugmail saying you were asking for review, but there are no patches on
> this bug, so I suspect a bugzilla bug may have trashed your attachments? Try
> again?

ReviewBoard failed to publish the patch for some reason.
Assignee: nobody → VYV03354
Status: NEW → ASSIGNED
Flags: needinfo?(VYV03354)
Comment on attachment 8874046 [details]
Bug 1326738 - Check for user-disabled images as well as broken images to determine if the broken icon should be displayed.

https://reviewboard.mozilla.org/r/145258/#review150000
Attachment #8874046 - Flags: review?(tnikkel) → review+
Pushed by VYV03354@nifty.ne.jp:
https://hg.mozilla.org/integration/autoland/rev/93a9ea3ab784
Check for user-disabled images as well as broken images to determine if the broken icon should be displayed. r=tnikkel
https://hg.mozilla.org/mozilla-central/rev/93a9ea3ab784
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
This already missed 54 and it doesn't look severe enough to worry about backporting to ESR52 either. Feel free to set the status back to affected and nominate it for approval if you feel otherwise, however.
Version: Trunk → 49 Branch
You need to log in before you can comment on or make changes to this bug.