Delete key in textarea moves text caret by 1px to the right

RESOLVED INVALID

Status

()

Core
Layout: Text
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: arni2033, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
>>>   My Info:   Win7_64, Nightly 49, 32bit, ID 20160526082509
STR_1:
1. Open attached "testcase 1"
2. Place text caret between symbols  n  and  '
3. Press Delete
4.(bonus) Keep pressing Ctrl+Z, Ctrl+Y to see the effect better (because caret won't blink)

AR:  Step 3 - Caret teleports by 1px to the right
ER:  Caret shouldn't move

Note:  I encountered this bug on https://vk.com/ when I was typing some text
(Reporter)

Updated

2 years ago
No longer blocks: 1277113
(Reporter)

Updated

2 years ago
Component: Untriaged → Layout: Text
Product: Firefox → Core
The testcase seems to be missing.
(Reporter)

Comment 2

2 years ago
Created attachment 8822962 [details]
testcase 1 - delete key moves caret.html
The Roboto font that you have embedded in the testcase includes a kern between the "n" and "'" glyphs. This in effect reduces the advance width of the "n" when it is followed by "'", and therefore the caret in the sequence "n'" appears one pixel further left than in the sequence "n ".

You can confirm that this is what's happening by adding "font-kerning:none" to the style; that will prevent Firefox applying the kern that's in the font, and the effect you're seeing will no longer occur.

So this isn't a bug, it is behaving correctly (although I'd question the wisdom of including such a kern in the font; I don't think the resulting spacing in the "n'" sequence looks good).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.