Open Bug 1326762 Opened 7 years ago Updated 1 year ago

Identity block stays in urlbar (and other bugs) after exiting Customize mode

Categories

(Firefox :: Toolbars and Customization, defect, P5)

36 Branch
defect

Tracking

()

REOPENED
Tracking Status
firefox50 --- wontfix
firefox51 --- wontfix
firefox52 --- fix-optional
firefox53 --- fix-optional
firefox54 --- wontfix
firefox55 --- wontfix
firefox56 --- wontfix
firefox57 --- fix-optional

People

(Reporter: arni2033, Unassigned)

References

Details

(Keywords: regression)

>>>   My Info:   Win7_64, Nightly 49, 32bit, ID 20160526082509
STR_1:
0. Launch new profile, open https://www.mozilla.org/en-US/firefox/nightly/firstrun/
1. Right-click Australis menu button, click "Customize..."
2. Press Escape to exit customize mode
3. Click in urlbar to select all text there, type "a" OR paste any text

4.(bonus - 1: break) Select typed/pasted text, drag and drop it to tabs toolbar to open in a new tab
5.(bonus - 2: repeat) If you performed Step 4, close the tab opened in Step 4, start from Step 1.
                      Otherwise click in urlbar, press Escape twice, start from Step 3.

AR:
 Step 3 - green doorhanger and identity info stays in identity block. Suggestions appear shifted.
 Step 4 - the tab is duplicated (read closely)
ER:
 Step 3 - as if there were no Steps 1,2 (green doorhanger and identity info should disappear)
 Step 4 - browser should open search results in Google or open url, depending on the dragging text

This is a regression.
No longer blocks: 1277113
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID 	20170117030218

I was able to reproduce the issue on the latest Firefox release (50.1.0) and on the latest Nightly (53.0a1).

Got as far as we can go bisecting nightlies...
Last good revision: be4ba3d5ca9a (2014-11-24)
First bad revision: 74edfbf0e6a3 (2014-11-25)
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=be4ba3d5ca9a&tochange=74edfbf0e6a3
Component: Untriaged → Location Bar
Version: Trunk → 36 Branch
hmm, nothing obvious in that regression range :(
I don't even know where to begin on this: comment 2 is right; there's nothing in that regression range that jumps out as problematic.  Gijs, do you know who might be able to look at this?
Flags: needinfo?(gijskruitbosch+bugs)
I don't really know what broke this and why... it looked fixed to me on Nightly (but it's not - read on!). I bisected the fix range with mozregression, and it ends up on bug 1344276, which added autocomplete results to empty profiles, which means the 'a' now autocompletes to 'amazon.com'. If you try with 'z', it's still busted on current nightly.

The fact that adding an autofill result here 'unbroke' things on Nightly means I suspect this is due to a change in autocomplete, specifically, bug 1083469 changed some autofill code to move from being (I guess) sync to being inside a Task.spawn() block, with a yield, which means it's now async, and presumably that triggers a race condition here. Marco could do something here, but he's very busy, so maybe Johann or Paolo can take a look, given their recent work on the identity block hiding/showing on typing?

For clarity, updated STR:

0. Launch new profile, which should open https://www.mozilla.org/en-US/firefox/nightly/firstrun/ immediately.
1. Right-click Australis menu button, click "Customize..."
2. Press Escape to exit customize mode
3. Click in urlbar to select all text there, type "z"

... and the identity block remains visible (ie we somehow fail to set pageproxystate to invalid).
Blocks: 1083469
Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(jhofmann)
As 54 was released, mark 54 won't fix.
I'm not able to reproduce from STR in Comment #4 in Nightly/57. Can you Gijs?
Flags: needinfo?(gijskruitbosch+bugs)
(In reply to Mike Taylor [:miketaylr] from comment #6)
> I'm not able to reproduce from STR in Comment #4 in Nightly/57. Can you Gijs?

I can still reproduce, yes. I don't think this needs to track 57, though.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(gijskruitbosch+bugs)
Resolution: --- → WORKSFORME
Gah, sorry.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
I may not have time to solve this issue in the near future, but if anyone wants to give it a shot I can describe the problem a little more precisely:

The function UpdatePageProxyState() (https://searchfox.org/mozilla-central/rev/5a60492a53667fc61a62af1847d005a210b7a4f6/browser/base/content/browser.js#2834) is called via "input" event listener on the urlbar. It compares urlbar.value to the last "valid" value and if that's different it sets pageproxystate to false.

Now, this works fine in all circumstances *except* the one described in this bug, where, mysteriously, gUrlbar.value still has the old value, in this case https://www.mozilla.org/en-US/firefox/nightly/firstrun/, instead of e.g. "z" (or whatever you just typed).

I can reproduce this every time I exit customize mode.
Flags: needinfo?(jhofmann)
Priority: -- → P5
Component: Address Bar → Toolbars and Customization
Severity: normal → S3
You need to log in before you can comment on or make changes to this bug.