M099 crashes moving mail folders [@ morkRowObject::SetRow]

VERIFIED WORKSFORME

Status

MailNews Core
Database
P2
critical
VERIFIED WORKSFORME
16 years ago
9 years ago

People

(Reporter: greer, Assigned: Bienvenu)

Tracking

({crash, topcrash})

Trunk
mozilla1.0
x86
All
crash, topcrash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

16 years ago
M099 is crashing at morkRowObject::SetRow for a lot of users. The prime user 
activity seems to be moving mail folders. 

I haven't seen any crashes at this signature in the Talkback data from the Trunk 
or any other release in the last ten days of data. 

morkRowObject::SetRow   50 

Stack Trace: 

         morkRowObject::SetRow  
[d:\builds\seamonkey\mozilla\db\mork\src\morkRowObject.cpp  line
465]
         nsMsgDatabase::CopyHdrFromExistingHdr
[d:\builds\seamonkey\mozilla\mailnews\db\msgdb\src\nsMsgDatabase.cpp  line 2724]
         nsMsgLocalMailFolder::EndCopy
[d:\builds\seamonkey\mozilla\mailnews\local\src\nsLocalMailFolder.cpp  line 
2485]
         nsCopyMessageStreamListener::EndCopy
[d:\builds\seamonkey\mozilla\mailnews\base\src\nsCopyMessageStreamListener.cpp  
line 164]
         nsMailboxProtocol::OnStopRequest
[d:\builds\seamonkey\mozilla\mailnews\local\src\nsMailboxProtocol.cpp  line 296]
         nsOnStopRequestEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsRequestObserverProxy.cpp  line 
213]
         PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  
line 591]
         PL_ProcessPendingEvents        
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  line
524]
         _md_EventReceiverProc  
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  line 1072]
         USER32.dll + 0x3c076 (0x77d7c076)
         USER32.dll + 0x3c076 (0x77d7c076)
         _except_handler3()
         kernel32.dll + 0x3bb86 (0x77e9bb86)
 
        Source File : 
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/db/mork/src/morkRowObject.cp
p line : 465
     (4275614)  URL: www.caedes.net
     (4275614)  Comments: copying a mail folder from my imported outlook express 
group to my mozilla default account group
     (4258989)  Comments: i was deleting all mails in a local mail folder. while 
it was deleting i changed to another mail account and pressed "get mail"
     (4222411)  Comments: deleting email
     (4130503)  Comments: moving folders in email
     (4091551)  Comments: moving from one folder to another a file
     (4088245)  Comments: Transfering large mailboxes (>2000 messages) from one 
folder to another within the mail client.
     (4081666)  Comments: moving mail folders after importing them from eudora
     (4068512)  URL: www.addonics.com
     (4068512)  Comments: selecting a mail folder
     (4068467)  URL: www.addonics.com
     (4056969)  Comments: moving email folders
     (4042873)  URL: ebay.com
     (4042873)  Comments: scrolling through newsgroup messages
     (4039077)  Comments: Moving folders around in messenger
     (4026916)  Comments: Copying a mail folder from one account to another
     (4026330)  Comments: arranging folders in the mail view
     (3992621)  Comments: Moving mail folders between accounts.
     (3991762)  Comments: re-organizing my email folders.
     (3981627)  Comments: Copied Mails from Mailbox to Mailbox
     (3935097)  Comments: I clicked on a mail folder
     (3935041)  Comments: Just moving mail folders around
     (3931410)  Comments: Highlight and deleting all mails in the "sent" folder 
(from sent to trash)
(Reporter)

Updated

16 years ago
Keywords: crash, topcrash

Updated

16 years ago
Keywords: nsbeta1+
Priority: -- → P2
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 1

16 years ago
this doesn't seem to be happening on the trunk, and hasn't happened on .9.9 in
more than 10 days. In fact, it seems to have fallen off the topcrash reports
completely, if I'm searching through the topcrash reports correctly. So, I'd
suggest wfm.

Comment 2

16 years ago
Actually, looking at the Talkback data, this is still a major topcrasher with
Mozilla 0.9.9.  

Bienvenu: You might have thought this hasn't happened in more than 10 days
because the build ids for M099 are MozillaBranch 2002031106 for Win32 and
2002031312 for Linux.

However, this hasn't happened with a MozillaTRUNK build since 3/2 and since no
one has been able to reproduce this after the release of M099, I'm going to mark
this worksforme for now.  If anyone is able to reproduce this with a recent
Trunk build, please reopen.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 3

16 years ago
yes, that's why I was confused. I'm not quite sure what's fixed on the trunk vs.
the branch, but I'll keep an eye on it.

Updated

16 years ago
QA Contact: gayatri → esther

Comment 4

16 years ago
Verified wfm...no crashes found with recent MozillaTrunk builds.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
Crash Signature: [@ morkRowObject::SetRow]
You need to log in before you can comment on or make changes to this bug.