All lines of canvas on the site are shifted diagonally [minecraft]

RESOLVED WORKSFORME

Status

Tech Evangelism
Desktop
RESOLVED WORKSFORME
a year ago
a year ago

People

(Reporter: arni2033, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
>>>   My Info:   Win7_64, Nightly 49, 32bit, ID 20160526082509
STR_1:
1. Open http://reindernijhoff.net/2014/04/js1k-post-mortem-minecraft/
2. Look at the canvas with minecraft landscape

AR:  All lines of canvas are shifted to the right: Nth line is shifted by N pixels
ER:  Obviously, the author hasn't plan it to work this way. It works OK on IE and GoogleChrome
     You can chek out (the same?) demo on js1k: http://js1k.com/2014-dragons/demo/1854

Notes:
1) This should be tested on zoom level = 100% on normal DPI (100%)
2) Well, currently it's unclear what is causing this bug on Firefox.
   Somebody (probably me?) will have to debug it to check what is causing it - if it appears to be
   some implementation mistake in Firefox, then component should be changed to "Core :: Canvas"
   Otherwise this bug should be resolved as Wontfix, I guess, because nobody cares for one single blog
3) All testcases on js1k are extremely minimized, but this one has readable sources.
   My plan was (first) to reproduce the same bug using readable sources (second) and then debug it
(Reporter)

Updated

a year ago
No longer blocks: 1277113
(Reporter)

Updated

a year ago
Component: Untriaged → Desktop
Product: Firefox → Tech Evangelism
(Reporter)

Updated

a year ago
See Also: → bug 1327927
Canvas looks normal to me.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.