Focusring switches to "enabled" mode EVEN for clicks if I open window via shortcut

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
2 years ago
10 months ago

People

(Reporter: arni2033, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
>>>   My Info:   Win7_64, Nightly 49, 32bit, ID 20160526082509
STR_1:
1.A) Click "Open a new window" toolbarbutton (may be located in Australis menu)
1.B) Press Ctrl+N to open a new window
2. Hover mouse over button "Downloads"
3. Hold left mouse button


STR_2:
0. Open devtools, move it to separate window, close devtools
1.A) Click developer toolbarbutton -> "Toggle Tools"
1.B) Press F12 to open devtools
2. Hover mouse over selected tab in devtools
3. Hold left mouse button


AR:
 A) STR_1, STR_2 - No focusring (good)
 B) STR_1, STR_2 - Annoying focusring appears in the element below mouse pointer (bad)
    Is it a "punishment" for knowing shortcuts?
ER:
 No focusring in scenario (B), as I use mouse and don't need accessibility features like focusring
(Reporter)

Updated

2 years ago
No longer blocks: 1277113
(Reporter)

Updated

2 years ago
Component: Untriaged → XP Toolkit/Widgets: XUL
Product: Firefox → Core

Comment 1

2 years ago
That sounds like the correct behaviour on Windows. Windows will enable focus rings for a window if a key was used to open it.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
Moving to Core:XUL per https://bugzilla.mozilla.org/show_bug.cgi?id=1455336
Component: XP Toolkit/Widgets: XUL → XUL
You need to log in before you can comment on or make changes to this bug.