Closed Bug 1327361 Opened 6 years ago Closed 3 years ago

Debugger doesn't display anything in "variables" when I navigate to another page and start debugging

Categories

(DevTools :: Debugger, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: arni2033, Unassigned)

References

Details

(Keywords: regression)

>>>   My Info:   Win7_64, Nightly 49, 32bit, ID 20160526082509
STR_1:
1. Open url data:text/html,<script>onclick=function(){console.log(F)}; function F(){return 0}</script>
2. Open devtools -> debugger
3. Set breakpoint at line 1
4. Focus urlbar, replace "(F)" with "(F())", press Enter
5. Set breakpoint at line 1. Click on the page

AR:  There's nothing in "variables" tab
ER:  All variables should be displayed correctly

This is regression from bug 1200798. Regression range:
> https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=15522bc2931a52ec435f22e233f747264b90f647&tochange=0e47cb06470145725732f0f362c46048969126d8
No longer blocks: 1277113
Component: Untriaged → Developer Tools: Canvas Debugger
Component: Developer Tools: Canvas Debugger → Developer Tools: Debugger
Product: Firefox → DevTools

I can't reproduce the problem anymore (also the STRs seem to be obsolete now)

Honza

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.