Closed Bug 1327375 Opened 5 years ago Closed 3 years ago

Background doesn't apply entirely to long message in console (+ text in other messages is wrapped incorrectly)

Categories

(DevTools :: Console, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1455645

People

(Reporter: arni2033, Unassigned)

References

Details

(Keywords: regression)

>>>   My Info:   Win7_64, Nightly 49, 32bit, ID 20160517030211
STR_1:
1. Open data:text/html,<script>var S='T_';for(i=0;i<9;i++)S+=S;eval(S);</script>
2. Open console, scroll messages by ~50px to the right (horizontally)

AR:
 Background of the first error in console unexpectedly ends at a random point.
 Filename of encoding error isn't placed at the right hand side
 
ER:  Any or all of the following:
 X) Console messages should take all width of console.
 Y) For each message with background: background should apply to the entire message
 Z) For each message with file name:  file name should be placed at the right hand side of the message
 T) Text in each console message should be wrapped according to the real width of message

Some messages (not necessarily as long as generated in my testcase) always cause overflow in console
because of bug 903676, so _this_ bug occurs.

This is regression from bug 1237368. Regression range:
> https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=ebaf5066ddd3c718cc2bd421f340809e6ab6f260&tochange=1aed451f1502dc6437d172c6a3e87f36a2a64bcc
No longer blocks: 1277113
Component: Untriaged → Developer Tools: Console
Product: Firefox → DevTools
Probably a dupe of Bug 1455645, which is now fixed. STR from Comment 0 now displays fine.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1455645
You need to log in before you can comment on or make changes to this bug.