URL bar locks up temporarily after bad links

RESOLVED DUPLICATE of bug 130480

Status

SeaMonkey
Location Bar
--
minor
RESOLVED DUPLICATE of bug 130480
16 years ago
9 years ago

People

(Reporter: Kit, Assigned: Joe Hewitt (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.9) Gecko/20020310
BuildID:    2002031008

When I try to reach an incorrect or broken URL, the URL bar locks up temporarily
after I dismiss the error message dialog box. I am not able to alter the URL or
type in the box for some time afterwards, though other functionality like
bookmarks remains.

After a varying period of time I will be able to type again. I think this may
also affect some text entry boxes on the page itself, too.

This only seems to happen when you press "return" to dismiss the dialog box,
rather than clicking on it with the pointer.

Reproducible: Always
Steps to Reproduce:
1.Enter a bad URL in the url bar (ex: http://bugs.mozilla.com/
2. Dismiss error message dialog box by pressing return, *not* by clicking OK.  
3. Attempt to type in the URL box or forms. Wait until the program allows you to
type again.

Actual Results:  It only works when you press return, but it is otherwise reliable.

Expected Results:  I would like to be able to immediately access the URL bar in
order to fix mistyped URLs, etc.

It almost seems as if the URL bar is lagging behind, though the browser and OS
are otherwise responsive, and the system has a very low load.

I experienced this problem in 0.9.8, too.

Comment 1

16 years ago
WFM W2K 2002031104.

Comment 2

16 years ago
worksforme with Linux build 20020321.
Is this bug 130480?

Comment 4

16 years ago
yes.

*** This bug has been marked as a duplicate of 130480 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

16 years ago
I am sorry I did not reply before, but I will confirm that this bug is a
duplicate of 130480. It is nice to know that someone else is having the problem.

Thank you for continuing to work on this bug.
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.