If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

mail hang on specific emails, probaby a css-thing?

RESOLVED FIXED

Status

SeaMonkey
MailNews: Message Display
--
critical
RESOLVED FIXED
16 years ago
13 years ago

People

(Reporter: Martin Fleurke, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows ME

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

When klicking on a received mail with HTML contents and stylesheets, mozilla
crashes, even in such way that the program can not be terminated. (I have to
exit windows and then I can terminate a dozen unindentified tasks).

I have seen other bug reports which are probably related/the same: 102056,
125256, 129485.

The mail crashing seems to be related to stylesheets within the mail. (it was
the only difference i could find) It has no scripts or microsoft-content as the
other bugs reported.

To "read" the mail I invented a little trick: minimize the view-pane of the mail
by maximizing the mail-index-pane (am i using the right terms?) In this way the
mail is not yet loaded when clicked on.

part of the mail:
--TriLab_BulkMailer_DNR
Content-Type: text/html; charset="ISO-8859-1"
Content-Transfer-Encoding: 8bit


<html>
<head>
	<title>Daily Newspaper Review</title>
<link href="http://www.iex.nl/iex.css" rel="stylesheet" type="text/css">
</head>

<body LEFTMARGIN=10 TOPMARGIN=10
background="http://img.iex.nl/images/mailing/images/backgrnd.gif">
<CENTER>
<TABLE WIDTH="600" BORDER="0" CELLSPACING="1" CELLPADDING="0" BGCOLOR="#3366CC">
	<TR>

Reproducible: Always
Steps to Reproduce:
1. click on a mail with css?


Actual Results:  mozilla makes an error and will be closed (says the warning,
but the closing hangs)

Expected Results:  mail to be viewed

Updated

16 years ago
QA Contact: olgam → esther

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 98626 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
A hang is technically (and even from a user's perspective) much different from a
crash.  correcting summary.

verified dup
Status: RESOLVED → VERIFIED
Summary: mail crashes on specific emails, probaby a css-thing? → mail hang on specific emails, probaby a css-thing?
(Reporter)

Comment 3

16 years ago
How can this be a duplicate of bug 98626? This bug has 0% CPU Usage. It just
lets Mozilla hang. (with no options to kill the hanging process under WinME, so
very annoying!)

however, it could be the background image causing the problem.
(Reporter)

Comment 4

15 years ago
This bug has been marked as a duplicate of 98626, but 98626 is fixed and I still
have this major problem of my cmputer hanging.

I am currently using Mozilla 1.2b build 2002101612 on WinMe.

To reproduce, simply browse to
http://home.student.utwente.nl/a.m.fleurke/message.eml. Mozilla will 'cause an
error in <unknown>' and after pressing 'ok', mozilla hangs and within no time
WinMe hangs too. I can not kill the mozilla program (by pressing ctl-alt-del
because it is not listed anymore in the list of running programs.

I have no CPU usage, so this bug seems quite different from 98626.

Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 5

15 years ago
Fixed (tested in mozilla 1.3b)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.