Drag-n-drop of selected tab to downloads toolbarbutton saves images from Twitter.com with wrong file name

RESOLVED DUPLICATE of bug 1327844

Status

()

Firefox
File Handling
RESOLVED DUPLICATE of bug 1327844
2 years ago
a year ago

People

(Reporter: arni2033, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
>>>   My Info:   Win7_64, Nightly 49, 32bit, ID 20160526082509
STR_1:
1. Open url https://pbs.twimg.com/media/Cwqc7ApWgAEfFJt.jpg:large in a new selected tab
2. Drag and drop selected tab to the downloads toolbarbutton
3. Open downloads panel, click on the file saved in Step 2

AR:
 Step 2 - Firefox saved image with name "Cwqc7ApWgAEfFJt.jpg large.jpg%20large".
 Step 3 - Windows7 can't open the file with extension ".jpg%20large"
ER:
 Step 2 - Firefox should save image with extension ".jpg"
(Reporter)

Updated

2 years ago
No longer blocks: 1277113
User Agent:  Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0

I have tested this issue on Windows 10 x64 with the latest Firefox release (50.1.0) and the latest Nightly (53.0a1-20170104030214) and managed to reproduce it following the steps in STR_1.
Component: Untriaged → File Handling

Comment 2

a year ago
Same cause as bug 1327844.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1327844
You need to log in before you can comment on or make changes to this bug.