When I block images on a site (https://vk.com/), almost all images are still displayed

RESOLVED INVALID

Status

()

Core
Image Blocking
RESOLVED INVALID
a year ago
10 months ago

People

(Reporter: arni2033, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [parity-Chrome] [gfx-noted])

(Reporter)

Description

a year ago
>>>   My Info:   Win7_64, Nightly 49, 32bit, ID 20160526082509
STR_1:
1. Open https://vk.com/wall-7736865_418381
2. Open "Page Info" -> Permissions, disable images. Close "Page Info"
3. Reload the page

AR:  Almost all images are displayed
ER:  No images
(Reporter)

Updated

a year ago
No longer blocks: 1277113
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0

I have verified this issue on Windows 8.1 x64 with latest Nightly (Build ID: 20170116030326) and latest Firefox release v50.1.0 and it is reproducible. I have followed the steps from Comment 0.
Component: Untriaged → Image Blocking
Product: Firefox → Core
Hi,

The images from vk.com are all blocked. The remaining images are not from vk.com. So, I'm not sure the real usage for the "Block images" in "Page Info".

:Ehsan, do you know the owner for image blocking?
Flags: needinfo?(ehsan)
Whiteboard: [parity-Chrome] → [parity-Chrome] [gfx-noted]

Comment 3

10 months ago
(In reply to Jerry Shih[:jerry] (UTC+8) from comment #2)
> Hi,
> 
> The images from vk.com are all blocked. The remaining images are not from
> vk.com. So, I'm not sure the real usage for the "Block images" in "Page
> Info".

What you are seeing is the intended usage.  The user revokes the permission from images to be loaded from vk.com and we do just that.  We still load other images from this page, such as https://pp.userapi.com/c543103/v543103564/1a4ad/MBITbNyakug.jpg because they are loaded from other unrelated sites.  The reporter is misunderstanding how this feature is supposed to work (which arguably doesn't have the best user experience!)

> :Ehsan, do you know the owner for image blocking?

There is no owner, this feature is unowned and unchanged in the last ~10+ years.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Flags: needinfo?(ehsan)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.