If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[e10s] navigation is canceled randomly

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
9 months ago
8 months ago

People

(Reporter: arni2033, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: read comment 2 first)

(Reporter)

Description

9 months ago
>>>   My Info:   Win7_64, Nightly 49, 32bit, ID 20160526082509
This bug appears randomly on different sites, usually while navigating by google urls.

Basic scnarios:
- (Shift+)Middle-click a link in a page
- Drag and drop a link to the tabs toolbar
- (!!!) Click a link on a page (vk.com/im) to navigate via history.pushState()
- Type/paste url into location bar, press Enter

In all of these cases navigation doesn't happen. In case navigation was triggered on about:newtab
(parent process tab), user ends up on a useless blank white page (see bug 1239887).
In case navigation was triggered on a normal page (content process tab), user stays on that page.
(Reporter)

Updated

9 months ago
No longer blocks: 1277113
I tested different navigation scenarios as you described and all work fine for me. I tested on  Windows 7 with 64 bit using:
 - Nightly 49.0a1, 32 bit, Build ID 20160502030207
 - Nightly 53.0a1, 32 bit, Build ID 20170104030214

Arni, is this reproducible for you on the latest Nightly or Firefox release? Could you please provide some pages where navigation did not work for you?
Flags: needinfo?(arni2033)
(Reporter)

Comment 2

9 months ago
Do not test this too hard! This is too random bug w/o reliable way to reproduce, it happens sometimes.
I just see this regularly while navigating on vk.com, Youtube, Google.
I think the only reason to keep this bug opened (in "unconfirmed" state) - to have an indication of
existing issue (if somebody will ever file report about this issue w/ reliable steps to reproduce).
Has STR: --- → no
Flags: needinfo?(arni2033)
Whiteboard: read comment 2 first
Tried again and could not reproduce on latest Nightly 54.0a1, closing this as Resolved - WFM.

If anyone can reproduce this, please feel free to reopen it and add more info about this issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.