Edit Page resends POST query without arguments

VERIFIED DUPLICATE of bug 115832

Status

SeaMonkey
Composer
VERIFIED DUPLICATE of bug 115832
16 years ago
13 years ago

People

(Reporter: I. Jakusziewski, Unassigned)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.9) Gecko/20020302
BuildID:    2002031004

The "Edit Page" menu command when issued for a page that was the
result of a POST form query resends the query without arguments.
(GET query is resent OK).
Similar error occurs for "Page Source" menu command isuued in same
situation.

Reproducible: Always
Steps to Reproduce:
1. Make HTML page containing a FORM with METHOD=POST
2. Make CGI script recieving argumante from the previous page and
   generating a HTML page showing their values
3. Deploy the pages on the web server
4. Open the first page in Mozilla, submit the form, get the second page
5. Issue "Edit page" or "Page Source" menu command
6. See the CGI script result, the arguments were not sent

Actual Results:  I saw in the Composer window (and in page source window too)
the page from my CGI script saying that the necessary argument
was not provided (instead of the page shown in browser window).
When I changed the original form to METHOD=GET instead of GET,
everything worked OK.

Expected Results:  Netscape 4.x browser opens Composer windows (or page source
window)
showing the same page that is in browser window. Mozilla should too.

Comment 1

16 years ago
repost on "edit page" is bug 115832.
repost on "view source" is bug 55583.

*** This bug has been marked as a duplicate of 115832 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
verified.
Status: RESOLVED → VERIFIED

Comment 3

15 years ago
reassign in case bugs are reopened
Assignee: syd → composer
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.