Closed Bug 1327746 Opened 8 years ago Closed 2 years ago

Inspector in browser toolbox doesn't always finds elements by selector [attribute="value"]

Categories

(DevTools :: Inspector, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: arni2033, Unassigned)

References

(Blocks 1 open bug)

Details

>>>   My Info:   Win7_64, Nightly 49, 32bit, ID 20160526082509
STR_1:
0. Open new Firefox window, close other Firefox windows
1. Move fullscreen toolbarbutton to Australis Menu.
2. Open browser toolbox, disable popup autohide, open Australis Menu
3. Inspect fullscreen toolbarbutton (only to make sure that ER is correct)
4. Focus search field "Search HTML", type/paste "[observes="View:FullScreen"]" w/o outer quotes,
   press Enter several times to find all matches.

AR:  Inspector doesn't find <toolbarbutton>
ER:  Inspector should find <toolbarbutton>, because it has that attribute (see Step 4)
No longer blocks: 1277113
Component: Untriaged → Developer Tools: Animation Inspector
Component: Developer Tools: Animation Inspector → Developer Tools: Inspector
Inspector bug triage (filter on CLIMBING SHOES).
Priority: -- → P3
Product: Firefox → DevTools

Just tried STR from Comment 0 with today's Nightly and it's working fine for me, the inspector does find the <toolbarbutton> element.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.