Browser doesn't immediately set new cursor after switching to another window

RESOLVED WORKSFORME

Status

()

Core
General
RESOLVED WORKSFORME
a year ago
7 months ago

People

(Reporter: arni2033, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
>>>   My Info:   Win7_64, Nightly 49, 32bit, ID 20160526082509
STR_1:  (original)
1. Open new tab about:blank in current FF window
2. Open scratchpad
3. Move mouse to the center of scratchpad window
4. Press Alt+Tab to switcth to the window from Step 1

AR:  Mouse cursor is still "crosshair"
ER:  Mouse cursor should be "default"


STR_2:  (testcase)
1. Open this url in a new maximized window: data:text/html,<style>html{height:100%;cursor:not-allowed}
2. Open this url in a new maximized window: data:text/html,<style>html{height:100%;cursor:col-resize}
3. Move mouse to the center of the window opened in Step 2
4. Press Alt+Tab to switch to window opened in Step 1

AR:  Mouse cursor is still "col-resize"
ER:  Mouse cursor should be "not-allowed"
(Reporter)

Updated

a year ago
Component: Untriaged → Untriaged
Product: Firefox → Core
(Reporter)

Updated

a year ago
No longer blocks: 1277113
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0

I have tried to reproduce this issue on latest FF release (51.0) and Nightly build (20170126030209) but without any luck. Mouse cursor switches from col-resize to not-allowed for me. 

Closing this bug as Resolved: Works for me. If anyone can still reproduce it, feel free to reopen the issue and provide more information.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
Moving from Core::Untriaged to Core::General https://bugzilla.mozilla.org/show_bug.cgi?id=1407598
Component: Untriaged → General
You need to log in before you can comment on or make changes to this bug.