Closed Bug 1327908 Opened 3 years ago Closed 3 years ago

Tooltips inconsistently disappear when I press Ctrl+L to type exactly what it says

Categories

(Core :: General, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla53
Tracking Status
firefox53 --- fixed

People

(Reporter: arni2033, Assigned: enndeakin)

References

(Depends on 1 open bug)

Details

Attachments

(1 file)

>>>   My Info:   Win7_64, Nightly 49, 32bit, ID 20160526082509
STR_1:
1. Open bug 1257815, click on the page
2. Hover mouse over text "1235542" to see the tooltip
3. Press Ctrl+L to focus urlbar and start typing contents of tooltip

AR:  Tooltip hides right when I'm going to start typing. In fact, it hides when I hold Ctrl.
ER:  Either X or Y.  X is better
 X) Firefox shouldn't hide tooltip to let me type
 Y) If you think that everything's as expected, then: In STR_2, STR_3 tooltip should hide
    when I hold Ctrl, for consistency reasons. Otherwise browser behavior will be illogical



STR_2:  (reference of good behavior)
1. Open bug 1257815
2. Focus urlbar
3. Hover mouse over text "1235542" to see the tooltip
4. Press Ctrl key

AR:  Tooltip doesn't disappear, just as expected



STR_3:  (reference of good behavior)
1. Open bookmarks sidebar
2. Click on this web page
3. Hover mouse over any bookmark to see the tooltip

AR:  Tooltip doesn't disappear, just as expected
No longer blocks: 1277113
Product: Firefox → Core
Arni2033,

This seems as a dupe of Bug 494139.

Please note that the same behavior is encountered also on Chrome 55.0.2883.87 m. 

Andrew, could you please express your opinion in regards to this issue?
Flags: needinfo?(overholt)
I think that Mozilla developers should first decide (possibly in bug 494139) for every keystroke/keypress whether or not they want to hide tooltip, and then resolve bug 494139, and then resolve this bug.
Note that marking this as dependent for bug 494139 will cause the situation when people can use bug 494139 as an excuse for not resolving this bug, but it's not completely incorrect: 494139 is filed as enhancement, and even if Mozilla developers will decide that it's not what they want to implement,this
bug will stay valid, as it describes that some tooltips do hide on keypress, while others do NOT hide.
Depends on: 494139
See Also: → 1240175
Is this related to e10s? http://searchfox.org/mozilla-central/source/layout/xul/nsXULTooltipListener.cpp#230,234 seems relevant.
Flags: needinfo?(overholt)
I'm probably missing something but I don't see why this is a Core issue.
Maybe Neil has an opinion.
Flags: needinfo?(enndeakin)
We've always hidden tooltips whenever any key is pressed.

This doesn't seem to happen with native Windows tooltips though, so perhaps we should remove it. On Mac and Linux though, tooltips do disappear when most keys are pressed, except modifier keys.
Flags: needinfo?(enndeakin)
Assignee: nobody → enndeakin
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8824176 - Flags: review?(felipc)
Attachment #8824176 - Flags: review?(felipc) → review+
Pushed by neil@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a12e66cb7bc2
on Windows, don't hide tooltips when a key is pressed. On other platforms, allow hiding tooltips when a key is pressed except when modifier keys are pressed alone, r=felipe
https://hg.mozilla.org/mozilla-central/rev/a12e66cb7bc2
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
QA Whiteboard: [good first verify]
Depends on: 1353764
I have reproduced this bug with Nightly 53.0a1 (2017-01-01) (64-bit) on Windows 7, 64 Bit!

This bug's fix is verified with latest Beta!

Build   ID : 20170403072723
User Agent : Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0

[bugday-20170405]
Moving from Core::Untriaged to Core::General https://bugzilla.mozilla.org/show_bug.cgi?id=1407598
Component: Untriaged → General
You need to log in before you can comment on or make changes to this bug.