Closed Bug 1327929 Opened 4 years ago Closed 3 years ago

[e10s] select's drop-down list is displayed even after another element is focused

Categories

(Core :: Layout: Form Controls, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1334155

People

(Reporter: arni2033, Unassigned)

References

(Blocks 1 open bug, )

Details

>>>   My Info:   Win7_64, Nightly 48, 32bit, ID 20160403030243
STR_1:
1. Open data:text/html,<select style="margin-left:80px"><option><option><option><option><option>
2. Click on <select>, then press Ctrl+L
RESULT:  Location bar is focused, but select's drop-down list isn't collapsed


STR_2:
0. Copy string "a" to clipboard
1. Open the following "data:" url or click URL in the form above
>   data:text/html,<script>setTimeout(function(){document.querySelector("input").focus()},3000);</script><form><input name="q"><select><option>
2. Type "aaaa" in input, press Enter, press Alt+Left, press Ctrl+Shift+R
3. Click on select in less than 3 seconds
4. Wait 3 seconds, then press Ctrl+V
RESULT:  <input> shows autocomplete suggestions, but <select>'s drop-down list is still visible


STR_3:
1. Type "asdf" in searchbar
2. Open data:text/html,<select style="margin-left:80px"><option><option><option><option><option>
3. Open select's drop-down list
4. Press Ctrl+K
5. Click identity-block
RESULT:  No caret in Searchbar. Drop-down list of options is displayed above identity panel


ER (1,2,3): Select's drop-down list should be collapsed once <select> loses focus

Note:  Compressed <select> is bug 1237485
No longer blocks: 1277113
Component: Untriaged → Layout: Form Controls
Product: Firefox → Core
Another e10s difference. Safari does it the e10s way, Chrome does it the non-e10s way.
This is no longer valid on Nightly 55. Going to see if I could get the fix commit by mozregression.
(In reply to Hsin-Yi Tsai [:hsinyi] from comment #2)
> This is no longer valid on Nightly 55. Going to see if I could get the fix
> commit by mozregression.

I got bug 1334155 by mozregression.

Going to close this.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1334155
You need to log in before you can comment on or make changes to this bug.