Closed Bug 1327949 Opened 3 years ago Closed 3 years ago

New tab toolbarbutton in navigation toolbar too large on Windows hidpi

Categories

(Firefox :: Toolbars and Customization, defect)

Unspecified
Windows
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 54
Tracking Status
firefox51 --- disabled
firefox52 --- verified
firefox-esr52 --- fixed
firefox53 --- verified
firefox54 --- verified

People

(Reporter: arni2033, Assigned: jkt)

References

Details

(Keywords: regression)

Attachments

(1 file)

>>>   My Info:   Win7_64, Nightly 53, 32bit, ID 20161219030207 (2016-12-19)
STR_1:
0. Set DPI -> 125% :
 A) Set DPI level -> 125% in your OS   [OR]
 B) Set layout.css.devPixelsPerPx -> 1.25
1. Move new tab toolbarbutton to navigation toolbar

AR:  The button is too big (huge)
ER:  Of normal size


This is regression from bug 1299669. Regression range:
> https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=74bcf8fa340454aa8218ea1e9dc8657e5f214160&tochange=76e0b210a4fc83a1411dbedba91a27fd7e46143a
Component: Untriaged → Toolbars and Customization
No longer blocks: 1277113
Jonathan, can you take a look?

Arni, bug 1299669 lists 51 as disabled. Is this really still an issue on 51? Can you find a regression range there?
Flags: needinfo?(jkt)
Flags: needinfo?(arni2033)
Will look into this.
Assignee: nobody → jkt
Flags: needinfo?(jkt)
@ Gijs:
Regression bug 1272256 has "milestone" set to "Firefox 51", that means that new tab toolbarbutton switched from "OK" to "broken_in_1st_way". Bug 1299669 switched it from "broken_in_1st_way" to "broken_in_2nd_way". I thought that status "disabled" in bug 1299669 is irrelevant, because there was no status "disabled" in bug 1272256. I wasn't aware that it was backed out in 51.
Flags: needinfo?(arni2033)
OS: Unspecified → Windows
Summary: New tab toolbarbutton in navigation toolbar broken since Firefox 51 → New tab toolbarbutton in navigation toolbar too large on Windows hidpi
Jonathan, have you had a chance to investigate?
Flags: needinfo?(jkt)
Hey sorry for not responding, I had not had time to look into this however will be trying to replicate today and get a fix in as soon as I can.
Thanks
Comment on attachment 8832271 [details]
Bug 1327949 - Fixing new tab icon in high DPI mode when moved to be the correct width

https://reviewboard.mozilla.org/r/108604/#review110556
Attachment #8832271 - Flags: review?(dao+bmo) → review+
Flags: needinfo?(jkt)
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/3b1115349c06
Fixing new tab icon in high DPI mode when moved to be the correct width r=dao
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/3b1115349c06
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 54
Please request Aurora/Beta approval on this when you get a chance.
Flags: needinfo?(jkt)
Comment on attachment 8832271 [details]
Bug 1327949 - Fixing new tab icon in high DPI mode when moved to be the correct width

Approval Request Comment
[Feature/Bug causing the regression]: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=74bcf8fa340454aa8218ea1e9dc8657e5f214160&tochange=76e0b210a4fc83a1411dbedba91a27fd7e46143a
[User impact if declined]: Dragging the plus icon to the toolbar in high DPI mode will have an oversized icon.
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: STR in bug description
[List of other uplifts needed for the feature/fix]: N/A
[Is the change risky?]: No
[Why is the change risky/not risky?]: One line of CSS that impacts icons only within windows.
[String changes made/needed]: N/A
Flags: needinfo?(jkt)
Attachment #8832271 - Flags: approval-mozilla-beta?
Attachment #8832271 - Flags: approval-mozilla-aurora?
Comment on attachment 8832271 [details]
Bug 1327949 - Fixing new tab icon in high DPI mode when moved to be the correct width

windows theme fix for nav bar, aurora53+, beta52+
Attachment #8832271 - Flags: approval-mozilla-beta?
Attachment #8832271 - Flags: approval-mozilla-beta+
Attachment #8832271 - Flags: approval-mozilla-aurora?
Attachment #8832271 - Flags: approval-mozilla-aurora+
I have reproduced this bug with Nightly 53.0a1 (2016-12-19) on Windows 8.1 (64 bit!).

This bug's fix is verified on Latest Nightly 53.0a2, Aurora 54.0a1, Beta 52.0b8.

Build ID : 20170222004022
User Agent : Mozilla/5.0 (Windows NT 6.3; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0

Build ID : 20170221030205
User Agent : Mozilla/5.0 (Windows NT 6.3; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0

Build ID : 20170220070057
User Agent : Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
(In reply to Azmina from comment #16)
> I have reproduced this bug with Nightly 53.0a1 (2016-12-19) on Windows 8.1
> (64 bit!).
> 
> This bug's fix is verified on Latest Nightly 53.0a2, Aurora 54.0a1, Beta
> 52.0b8.
> 
> Build ID : 20170222004022
> User Agent : Mozilla/5.0 (Windows NT 6.3; WOW64; rv:53.0) Gecko/20100101
> Firefox/53.0
> 
> Build ID : 20170221030205
> User Agent : Mozilla/5.0 (Windows NT 6.3; WOW64; rv:54.0) Gecko/20100101
> Firefox/54.0
> 
> Build ID : 20170220070057
> User Agent : Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101
> Firefox/52.0

Thanks!
You need to log in before you can comment on or make changes to this bug.