Retry icon in downloads window aligned wrong

RESOLVED WORKSFORME

Status

()

Firefox
Downloads Panel
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: arni2033, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
>>>   My Info:   Win7_64, Nightly 53, 32bit, ID 20161119030204 (2016-11-19)
STR_1:
1. Copy "http://127.0.0.1/" to clipboard
2. Open all downloads, paste text copied in Step 1
3. Hover mouse over "Retry" button

AR:  The icon inside the button is misplaced
ER:  The icon inside the button should be located at the very center of the circle


STR_2:  (HiDPI)
1. Copy "http://example.org/" to clipboard
2. Open all downloads, paste text copied in Step 1
3. Hover mouse over "Open Containing folder" button

AR:  The icon inside the button is misplaced
ER:  The icon inside the button should be located at the very center of the circle


Notes:
1) The issue is more noticeable on HiDPI (DPI set to 125%)
2) This type of issues in Mozilla is surprisingly persistent, as if nobody ever checked new design
(Reporter)

Updated

2 years ago
No longer blocks: 1277113

Comment 1

2 years ago
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0

I have tested the reported issue on latest FF release (50.1.0) and latest Nightly build and could not reproduce it. I have used layout.css.devPixelsPerPx set to 1.5 in order to set HiDPI with the provided steps, but no success.
 
Can you please provide screen shot showing the issue or can you to verify the issue is still present in the current Nightly build?
Status: NEW → UNCONFIRMED
Ever confirmed: false

Comment 2

2 years ago
Created attachment 8824752 [details]
screenshot 1 - bug 1327951.png

>>>   My Info:   Win7_64, Nightly 53, 32bit, ID 20170104030214 (2017-01-04)
Reproducible
Flags: needinfo?(stefan.georgiev)

Comment 3

2 years ago
We have tested again the issue and looked into the attachment, but I can't still see issue. Can someone from Downloads:Panel team look into this ?
Component: Untriaged → Downloads Panel
Flags: needinfo?(stefan.georgiev)

Comment 4

2 years ago
I don't see a visible misalignment either. Even if it is prominent in some configurations, arguably the fact that the icon is not perfectly centered is a feature of the design, and not a bug. Also, even if it was a bug, I don't think it's specifically something we need to fix, given it's inside the secondary Downloads View user interface, which we may want to redesign to make it more similar to the Downloads Panel.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME

Updated

2 years ago
Keywords: regression, regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.