Last Comment Bug 1327972 - Alt+Left/Right doesn't navigate in tab history if I clicked a button in devtools toolbar
: Alt+Left/Right doesn't navigate in tab history if I clicked a button in devto...
Status: VERIFIED FIXED
: regression
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: Unspecified Unspecified
P2 normal (vote)
: Firefox 53
Assigned To: Yura Zenevich [:yzen]
:
: J. Ryan Stinnett [:jryans] (use ni?)
Mentors:
Depends on:
Blocks: 1242852
  Show dependency treegraph
 
Reported: 2017-01-01 03:17 PST by arni2033
Modified: 2017-02-06 10:23 PST (History)
8 users (show)
andrei.vaida: qe‑verify+
See Also:
Crash Signature:
(edit)
QA Whiteboard: [bugday-20170118], [testday-20170203]
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
wontfix
verified
verified
affected


Attachments
1327972 patch (1.47 KB, patch)
2017-01-18 07:59 PST, Yura Zenevich [:yzen]
jryans: review+
jcristau: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description User image arni2033 2017-01-01 03:17:42 PST
>>>   My Info:   Win7_64, Nightly 49, 32bit, ID 20160526082509
STR_1:
1. Open new tab. Focus urlbar, type "data:,a", press Enter. Focus urlbar, type "data:,b", press Enter.
2. Open devtools
3. Click on button "Responsive design mode" in devtools toolbar. Click the same button again
4. Press Alt+Left

AR:  No visible action
ER:  Browser should navigate to "data:,a"

This is regression from bug 1242852. Regression range:
> https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=5d450730e3e29949ae9556bec510c0e009e10262&tochange=43a78545f93f6eabbf4b5b581bd3790915f0c1a1@ Yura Zenevich [:yzen]:
It seems that this is a regresion caused by your change. Please have a look.
Comment 1 User image J. Ryan Stinnett [:jryans] (use ni?) 2017-01-05 11:14:48 PST
It seems the toolbox grabs focus and eats the back / forward page navigation shortcuts.

Maybe one of :bgrins / :yzen can help?
Comment 2 User image (Unavailable until Apr 3) [:bgrins] 2017-01-13 15:48:26 PST
(In reply to J. Ryan Stinnett [:jryans] (use ni?) from comment #1)
> It seems the toolbox grabs focus and eats the back / forward page navigation
> shortcuts.
> 
> Maybe one of :bgrins / :yzen can help?

If we are intending to only take the left/right keys then I think we should skip handing when alt/cmd is held to avoid this. Yura, what's the intended behavior with left/right here?
Comment 3 User image Yura Zenevich [:yzen] 2017-01-18 06:58:10 PST
(In reply to Brian Grinstead [:bgrins] from comment #2)
> (In reply to J. Ryan Stinnett [:jryans] (use ni?) from comment #1)
> > It seems the toolbox grabs focus and eats the back / forward page navigation
> > shortcuts.
> > 
> > Maybe one of :bgrins / :yzen can help?
> 
> If we are intending to only take the left/right keys then I think we should
> skip handing when alt/cmd is held to avoid this. Yura, what's the intended
> behavior with left/right here?

Yeah I agree, left/right (with no opt keys) allows for keyboard navigation in toolbar so we should bail if alt/cmd keys are used when arrows are handled.
Comment 4 User image Yura Zenevich [:yzen] 2017-01-18 07:59:09 PST
Created attachment 8827959 [details] [diff] [review]
1327972 patch
Comment 5 User image J. Ryan Stinnett [:jryans] (use ni?) 2017-01-18 14:26:31 PST
Comment on attachment 8827959 [details] [diff] [review]
1327972 patch

Review of attachment 8827959 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me, thanks for working on it!
Comment 6 User image Pulsebot 2017-01-19 14:11:07 PST
Pushed by yura.zenevich@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d6f80f3a2400
make sure alt/cmd+lefr/right navigate history even if devtools toolbar is focused. r=jryans
Comment 7 User image Wes Kocher (:KWierso) 2017-01-19 16:45:47 PST
https://hg.mozilla.org/mozilla-central/rev/d6f80f3a2400
Comment 8 User image Nazir Ahmed Sabbir [:NaSb] 2017-01-20 01:48:15 PST
Successfully managed to reproduce this bug on Nightly 49.0a1 (2016-05-26) (Build ID: 20160526030223) by the following Comment 0's instruction!

This issue is now verified as fixed on Latest Firefox Nightly 53.0a1 (2017-01-19) (64-bit)

Build ID: 20170119222621
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0
OS: Linux 4.4.0-57-generic; elementary OS 0.4
Comment 9 User image Ryan VanderMeulen [:RyanVM] 2017-01-20 13:42:35 PST
Please request Aurora approval on this when you get a chance.
Comment 10 User image Yura Zenevich [:yzen] 2017-01-20 13:47:42 PST
Comment on attachment 8827959 [details] [diff] [review]
1327972 patch

Approval Request Comment
[Feature/Bug causing the regression]: bug 1242852
[User impact if declined]: keyboard shortcuts for history navigation won't work if use is also focused on the dev tools toolbar.
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]:  yes, as described in Description.
[List of other uplifts needed for the feature/fix]:
[Is the change risky?]: no
[Why is the change risky/not risky?]: filter keyboard events if there are modifiers present, so not too complicated
[String changes made/needed]: none
Comment 11 User image Julien Cristau [:jcristau] 2017-01-24 06:23:17 PST
Comment on attachment 8827959 [details] [diff] [review]
1327972 patch

let navigation shortcuts work with devtools focused, beta52+
Comment 12 User image Ryan VanderMeulen [:RyanVM] 2017-01-24 12:27:50 PST
https://hg.mozilla.org/releases/mozilla-beta/rev/07692c9040cf
Comment 13 User image Md.Majedul isalm 2017-01-31 21:54:20 PST
I have reproduced this bug with Nightly 49.0a1 (2016-05-26) (64-bit) on ubuntu 16.10 , 64 Bit !

This bug's fix is verified with latest Beta & Aurora!
Aurora:
Build   ID    	20170131084239
User Agent      Mozilla/5.0 (X11; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0
 Beta:  
Build ID        20170130065342                                       
 User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0

[bugday-20170201]
Comment 14 User image Tanvir Rahman 2017-02-05 04:31:06 PST
I have reproduced this bug with Nightly 53.0a1 (2017-01-01) (64-bit)

The Bug's fix is now verified on latest Beta and Aurora

Aurora:
Build ID 	20170205004004
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0

Beta:
Build ID 	20170130065342
User Agent 	Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0

[testday-20170203]

Note You need to log in before you can comment on or make changes to this bug.