Closed Bug 1328008 Opened 3 years ago Closed 2 years ago

JSON View: copying a single text value - round 2, fight

Categories

(DevTools :: JSON Viewer, defect)

48 Branch
defect
Not set

Tracking

(firefox-esr52 wontfix, firefox55 wontfix, firefox56 fixed, firefox57 fixed)

RESOLVED FIXED
Firefox 57
Tracking Status
firefox-esr52 --- wontfix
firefox55 --- wontfix
firefox56 --- fixed
firefox57 --- fixed

People

(Reporter: arni2033, Assigned: Oriol)

References

Details

(Keywords: regression)

Attachments

(1 file)

>>>   My Info:   Win7_64, Nightly 49, 32bit, ID 20160526082509
Text values longer than N characters are shortened, and expanded on click. For instance I have a value that looks like this:

"https://msdn.microsoft.c.../mt146826(v=vs.94).aspx"

and clicking it expands it as:

"https://msdn.microsoft.com/en-us/library/mt146826(v=vs.94).aspx"

Once expanded, I want to select and copy it. I click at the start of the text, drag to the right, release the click to end the selection� and the text gets shortened and kills my selection.

The solution seems to be to start clicking outside of the text value, so that one doesn't trigger a click-that-toggles-the-value. Doable but hard to figure out.

See also:
https://bugzilla.mozilla.org/show_bug.cgi?id=1223143#c7


>>>   My Info:   Win7_64, Nightly 49, 32bit, ID 20160526082509
STR_1:
1. Open url  https://hg.mozilla.org/mozilla-central/json-pushes?changeset=f8bdceb55c9d&full=1
2. Select via mouse the 1st occurrence of string "Bug 384458" on the page
3. Press Ctrl+C

AR:  When I release left mouse button, all selection is canceled. Can't select and copy the text
ER:  After Step 3 text "Bug 384458" should be copied to clipboard

Note:  Bug 1243951 comment 2 asks for complaints. Here's a complaint.

This is regression from 1256757. Regression range:
> https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=216d9ae88a315bed4961b121fb96f930411cf4b2&tochange=3ce5d23d337f45ae96100c00ab994b53d202d7c4@ Jan Honza Odvarko [:Honza] (PTO: 12/09-01/01):
It seems that this is a regresion caused by your change. Please have a look.
No longer blocks: 1277113
Component: Untriaged → Developer Tools: JSON Viewer
Duplicate of this bug: 1362751
This restores the behavior from bug 1232634: nodes are only toggled by clicking labels. Clicking a value still selects the row, though.
Assignee: nobody → oriol-bugzilla
Status: NEW → ASSIGNED
Attachment #8902696 - Flags: review?(odvarko)
Comment on attachment 8902696 [details] [diff] [review]
json-collapse.patch

Review of attachment 8902696 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for the patch, the UX is a lot better now!

R+ assuming try is green.

Honza
Attachment #8902696 - Flags: review?(odvarko) → review+
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/383c01a3dcb0
Stop collapsing TreeView nodes when clicking a value. r=Honza
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/383c01a3dcb0
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Is this something we should consider nominating for Beta approval for DevEdition users?
Flags: needinfo?(oriol-bugzilla)
Flags: in-testsuite+
Version: Trunk → 48 Branch
Not being able to select long strings is very disrupting, so maybe it should be uplifted indeed.
Honza, what do you think?
Flags: needinfo?(oriol-bugzilla) → needinfo?(odvarko)
Comment on attachment 8902696 [details] [diff] [review]
json-collapse.patch

Approval Request Comment
[Feature/Bug causing the regression]: bug 1232634
[User impact if declined]: Selection of long strings (in the JSON Viewer) is disrupting
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: n/a
[List of other uplifts needed for the feature/fix]: n/a
[Is the change risky?]: no
[Why is the change risky/not risky?]: simple patch and affects only developers.
[String changes made/needed]: n/a
Flags: needinfo?(odvarko)
Attachment #8902696 - Flags: approval-mozilla-beta?
Comment on attachment 8902696 [details] [diff] [review]
json-collapse.patch

Fix a regression and include a test. Beta56+.
Attachment #8902696 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.