Closed Bug 1328028 Opened 3 years ago Closed 3 years ago

Cut-Copy-Paste are NOW broken, Episode 5 - All items are enabled for users who disabled malicious clipboard API

Categories

(Core :: DOM: Events, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1271897

People

(Reporter: arni2033, Unassigned)

References

Details

(Keywords: regression, Whiteboard: Cut, copy, paste buttons intentionally broken in bug 1159490 by Ehsan Akhgari)

>>>   My Info:   Win7_64, Nightly 49, 32bit, ID 20160526082509
STR_1:
1. Open about:config, set pref "dom.event.clipboardevents.enabled" to "false"
2. Copy text "asdf" to clipboard
3. Open url   data:text/html,<input>
4. Right-click in <input>

AR:  All are enabled
ER:  There's no need to work around "weaknesses" of whatever malicious API.
     Everything should work just like before regression 1159490: Step 4 - all items should be disabled
Component: Untriaged → DOM: Events
Product: Firefox → Core
No longer blocks: 1277113
I'm confused. The API is unrelated to the menu that allows uses to paste stuff into inputs? So I don't see why dom.event.clipboardevents.enabled would affect the ability to paste via the right-click menu?
(In reply to Marcos Caceres [:marcosc] from comment #1)
> I'm confused. The API is unrelated to the menu that allows uses to paste
> stuff into inputs? So I don't see why dom.event.clipboardevents.enabled
> would affect the ability to paste via the right-click menu?

The test results showed that this preference did have nothing to do with the ability. I got the same behavior with both values.
See bug 1271897 comment 5.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1271897
You need to log in before you can comment on or make changes to this bug.