Closed Bug 1328043 Opened 5 years ago Closed 5 years ago

Iframe isn't scrolled into view when I focus it

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla53
Tracking Status
firefox50 --- wontfix
firefox51 --- wontfix
firefox52 --- wontfix
firefox53 --- verified

People

(Reporter: arni2033, Assigned: enndeakin)

References

(Regressed 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file)

>>>   My Info:   Win7_64, Nightly 49, 32bit, ID 20160526082509
STR_1:
1. Open url   data:text/html,<button>B</button><br><iframe style="margin-top:10000px;height:400px">
2. Click on button "B"
3. Press Tab key once

AR:  Focused iframe is not scrolled into view
ER:  The iframe should be scrolled into view

Note:
 This usually happens on the page with a left and right "columns" with content. The left one is the
 article/comments/youtube video, and the right one contains some related links, but starts with iframe
 When I press Tab key to navigate to the last link/focusable item in the left column, then press Tab
 once again, nothing happens. Focusring just disappears from visible part of the page.

This is regression from bug 178324 (between 2009-06-10 and 2009-06-11). Regression range:
> http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=90d3e6d2cbb9&tochange=4430cae50dad@ Neil Deakin:
It seems that this is a regresion caused by your change. Please have a look.
No longer blocks: 1277113
Product: Firefox → Core
User Agent:  Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0

I have tested this issue on Windows 10 x64 with the latest Firefox release (50.1.0) and the latest Nightly (53.0a1-20170103030204) and managed to reproduce it.
After following the STR_1, when pressing the tab key once the iframe isn't scrolled into view.

Neil, can you please take a look at this?
Component: Untriaged → XUL
Flags: needinfo?(enndeakin)
Component: XUL → Keyboard: Navigation
Flags: needinfo?(enndeakin)
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Attachment #8823751 - Flags: review?(bugs)
Attachment #8823751 - Flags: review?(bugs) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/15748795cb4b4450cbb198b030af29b7f273d46e
Bug 1328043, scrolling into view on focus should happen even when event shouldn't fire, fixes tabbing into blank iframes, r=smaug
https://hg.mozilla.org/mozilla-central/rev/15748795cb4b
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Emil, can you please verify that this issue is fixed with the next Nightly? Thanks!
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0

The issue is no longer reproducible on the latest Nightly (53.0a1-20170110030221).
Flags: needinfo?(emil.pasca)
Thanks, Emil!

Hi Neil, can you please request Aurora (and Beta if suitable) approval on this? Thanks!
Flags: needinfo?(enndeakin)
Status: RESOLVED → VERIFIED
This bug has existed for at least 8 years, so I don't see why that is necessary.
Flags: needinfo?(enndeakin)
Component: Keyboard: Navigation → User events and focus handling
Regressions: 1670534
You need to log in before you can comment on or make changes to this bug.